Bug 826322 - YUM fails to update Fedora 17 after upgrade from Fedora 16.
YUM fails to update Fedora 17 after upgrade from Fedora 16.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 22:30 EDT by Grzegorz Witkowski
Modified: 2014-01-21 18:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 14:50:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grzegorz Witkowski 2012-05-29 22:30:48 EDT
Description of problem:

Upgraded Fedora 16 to Fedora 17 using full DVD release.
Now yum update fails.

How reproducible:

# yum clean all
# yum check-update
# yum update

  
Actual results:

Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
libcups.so.2 is needed by gtk2-2.24.10-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 179 pre-existing rpmdb problem(s), 'yum check' output follows:
ConsoleKit-x11-0.4.5-1.fc15.x86_64 has missing requires of ConsoleKit = ('0', '0.4.5', '1.fc15')
GConf2-gtk-3.2.3-1.fc16.x86_64 has missing requires of GConf2 = ('0', '3.2.3', '1.fc16')
abrt-retrace-client-2.0.7-2.fc16.x86_64 has missing requires of abrt = ('0', '2.0.7', '2.fc16')
alsa-lib-1.0.25-3.fc17.x86_64 is a duplicate with alsa-lib-1.0.25-1.fc16.i686
alsa-plugins-pulseaudio-1.0.25-3.fc17.x86_64 is a duplicate with alsa-plugins-pulseaudio-1.0.25-3.fc16.i686
atk-2.4.0-1.fc17.x86_64 is a duplicate with atk-2.2.0-2.fc16.i686
audit-libs-2.2.1-1.fc17.x86_64 is a duplicate with audit-libs-2.2.1-1.fc16.i686
avahi-libs-0.6.30-7.fc17.x86_64 is a duplicate with avahi-libs-0.6.30-4.fc16.i686
cairo-1.10.2-7.fc17.x86_64 is a duplicate with cairo-1.10.2-4.fc16.i686
caribou-antler-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
caribou-gtk2-module-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
caribou-gtk3-module-0.4.1-3.fc16.x86_64 has missing requires of caribou = ('0', '0.4.1', '3.fc16')
cracklib-2.8.18-3.fc17.x86_64 is a duplicate with cracklib-2.8.18-2.fc15.i686
db4-4.8.30-10.fc17.x86_64 is a duplicate with db4-4.8.30-3.fc15.i686
1:dbus-libs-1.4.10-4.fc17.x86_64 is a duplicate with 1:dbus-libs-1.4.10-3.fc16.i686
dconf-editor-0.10.0-1.fc16.x86_64 has missing requires of dconf = ('0', '0.10.0', '1.fc16')
expat-2.1.0-1.fc17.x86_64 is a duplicate with expat-2.1.0-1.fc16.i686
farsight2-python-0.0.31-1.fc16.x86_64 has missing requires of farsight2 = ('0', '0.0.31', '1.fc16')
farsight2-python-0.0.31-1.fc16.x86_64 has missing requires of libgstfarsight-0.10.so.0()(64bit)
flac-1.2.1-9.fc17.x86_64 is a duplicate with flac-1.2.1-8.fc16.i686
fontconfig-2.8.0-6.fc17.x86_64 is a duplicate with fontconfig-2.8.0-4.fc16.i686
freetype-2.4.8-3.fc17.x86_64 is a duplicate with freetype-2.4.6-5.fc16.i686
gamin-0.1.10-12.fc17.x86_64 is a duplicate with gamin-0.1.10-10.fc16.i686
gd-2.0.35-16.fc17.x86_64 is a duplicate with gd-2.0.35-14.fc16.i686
gdk-pixbuf2-2.26.1-1.fc17.x86_64 is a duplicate with gdk-pixbuf2-2.24.1-1.fc16.i686
glib2-2.32.1-1.fc17.x86_64 is a duplicate with glib2-2.30.3-1.fc16.i686
glibc-2.14.90-24.fc16.7.i686 has missing requires of glibc-common = ('0', '2.14.90', '24.fc16.7')
glibc-2.15-37.fc17.x86_64 is a duplicate with glibc-2.14.90-24.fc16.7.i686
3:gnome-commander-1.2.8.15-1.fc16.x86_64 has missing requires of libexiv2.so.10()(64bit)
3:gnome-commander-1.2.8.15-1.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
gnome-vfs2-smb-2.24.4-6.fc16.x86_64 has missing requires of gnome-vfs2 = ('0', '2.24.4', '6.fc16')
gnutls-2.12.17-1.fc17.x86_64 is a duplicate with gnutls-2.12.14-2.fc16.i686
gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 has missing requires of libcdio.so.12()(64bit)
gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
gtk2-2.24.8-3.fc16.i686 has missing requires of libcups.so.2
gtk2-2.24.10-1.fc17.x86_64 is a duplicate with gtk2-2.24.8-3.fc16.i686
gts-0.7.6-15.fc15.x86_64 has missing requires of libnetpbm.so.10()(64bit)
ibus-hangul-1.4.1-2.fc16.x86_64 has missing requires of libibus-1.0.so.0()(64bit)
jack-audio-connection-kit-example-clients-1.9.8-3.fc16.x86_64 has missing requires of jack-audio-connection-kit = ('0', '1.9.8', '3.fc16')
jasper-libs-1.900.1-19.fc17.x86_64 is a duplicate with jasper-libs-1.900.1-18.fc16.i686
keyutils-libs-1.5.5-2.fc17.x86_64 is a duplicate with keyutils-libs-1.5.2-1.fc16.i686
krb5-libs-1.10-5.fc17.x86_64 is a duplicate with krb5-libs-1.9.3-1.fc16.i686
lcms-libs-1.19-5.fc17.x86_64 is a duplicate with lcms-libs-1.19-4.fc16.i686
libICE-1.0.8-1.fc17.x86_64 is a duplicate with libICE-1.0.7-1.fc16.i686
libSM-1.2.1-1.fc17.x86_64 is a duplicate with libSM-1.2.0-2.fc15.i686
libX11-1.4.3-1.fc16.i686 has missing requires of libX11-common = ('0', '1.4.3', '1.fc16')
libX11-1.4.99.901-2.fc17.x86_64 is a duplicate with libX11-1.4.3-1.fc16.i686
libXScrnSaver-1.2.2-1.fc17.x86_64 is a duplicate with libXScrnSaver-1.2.1-2.fc15.i686
libXau-1.0.6-3.fc17.x86_64 is a duplicate with libXau-1.0.6-2.fc15.i686
libXaw-1.0.9-3.fc17.x86_64 is a duplicate with libXaw-1.0.8-1.fc15.i686
libXcomposite-0.4.3-3.fc17.x86_64 is a duplicate with libXcomposite-0.4.3-2.fc15.i686
libXcursor-1.1.13-1.fc17.x86_64 is a duplicate with libXcursor-1.1.11-3.fc15.i686
libXdamage-1.1.3-3.fc17.x86_64 is a duplicate with libXdamage-1.1.3-2.fc15.i686
libXext-1.3.1-1.fc17.x86_64 is a duplicate with libXext-1.3.0-1.fc16.i686
libXfixes-5.0-2.fc17.x86_64 is a duplicate with libXfixes-5.0-1.fc16.i686
libXft-2.3.0-2.fc17.x86_64 is a duplicate with libXft-2.2.0-2.fc15.i686
libXi-1.6.1-1.fc17.x86_64 is a duplicate with libXi-1.4.5-1.fc16.i686
libXinerama-1.1.2-1.fc17.x86_64 is a duplicate with libXinerama-1.1.1-2.fc15.i686
libXmu-1.1.0-3.fc17.x86_64 is a duplicate with libXmu-1.1.0-2.fc15.i686
libXpm-3.5.10-1.fc17.x86_64 is a duplicate with libXpm-3.5.8-3.fc15.i686
libXrandr-1.3.1-3.fc17.x86_64 is a duplicate with libXrandr-1.3.1-2.fc15.i686
libXrender-0.9.7-1.fc17.x86_64 is a duplicate with libXrender-0.9.6-2.fc15.i686
libXt-1.1.2-2.fc17.x86_64 is a duplicate with libXt-1.1.1-1.fc16.i686
libXtst-1.2.0-3.fc17.x86_64 is a duplicate with libXtst-1.2.0-2.fc15.i686
libXv-1.0.7-1.fc17.x86_64 is a duplicate with libXv-1.0.6-2.fc15.i686
libXxf86vm-1.1.2-1.fc17.x86_64 is a duplicate with libXxf86vm-1.1.1-2.fc15.i686
libasyncns-0.8-3.fc17.x86_64 is a duplicate with libasyncns-0.8-2.fc15.i686
libcom_err-1.42-4.fc17.x86_64 is a duplicate with libcom_err-1.41.14-2.fc15.i686
libdrm-2.4.33-1.fc17.x86_64 is a duplicate with libdrm-2.4.33-1.fc16.i686
libexif-0.6.20-2.fc17.x86_64 is a duplicate with libexif-0.6.20-1.fc16.i686
libffi-3.0.10-2.fc17.x86_64 is a duplicate with libffi-3.0.10-1.fc16.i686
libgcc-4.7.0-5.fc17.x86_64 is a duplicate with libgcc-4.6.3-2.fc16.i686
libgcj-4.6.3-2.fc16.x86_64 has missing requires of libgmp.so.3()(64bit)
libgcrypt-1.5.0-3.fc17.x86_64 is a duplicate with libgcrypt-1.5.0-2.fc16.i686
libgpg-error-1.10-2.fc17.x86_64 is a duplicate with libgpg-error-1.10-1.fc16.i686
libgphoto2-2.4.11-3.fc17.x86_64 is a duplicate with libgphoto2-2.4.11-1.fc16.i686
libgpod-sharp-0.8.2-1.fc16.x86_64 has missing requires of libgpod = ('0', '0.8.2', '1.fc16')
libieee1284-0.2.11-11.fc17.x86_64 is a duplicate with libieee1284-0.2.11-10.fc15.i686
libjpeg-turbo-1.2.0-1.fc17.x86_64 is a duplicate with libjpeg-turbo-1.2.0-1.fc16.i686
libjpeg-turbo-utils-1.2.0-1.fc16.x86_64 has missing requires of libjpeg-turbo(x86-64) = ('0', '1.2.0', '1.fc16')
libmng-1.0.10-6.fc17.x86_64 is a duplicate with libmng-1.0.10-5.fc15.i686
2:libogg-1.2.2-4.fc17.x86_64 is a duplicate with 2:libogg-1.2.2-3.fc15.i686
libpciaccess-0.13-2.fc17.x86_64 is a duplicate with libpciaccess-0.12.1-1.fc15.i686
2:libpng-1.5.10-1.fc17.x86_64 is a duplicate with 2:libpng-1.2.49-1.fc16.i686
libproxy-python-0.4.7-1.fc16.noarch has missing requires of libproxy = ('0', '0.4.7', '1.fc16')
libreport-plugin-reportuploader-2.0.8-4.fc16.x86_64 has missing requires of libreport = ('0', '2.0.8', '4.fc16')
libselinux-2.1.10-3.fc17.x86_64 is a duplicate with libselinux-2.1.6-6.fc16.i686
libsndfile-1.0.25-2.fc17.x86_64 is a duplicate with libsndfile-1.0.25-1.fc16.i686
libstdc++-4.7.0-5.fc17.x86_64 is a duplicate with libstdc++-4.6.3-2.fc16.i686
libtasn1-2.12-1.fc17.x86_64 is a duplicate with libtasn1-2.12-1.fc16.i686
libthai-0.1.14-5.fc17.x86_64 is a duplicate with libthai-0.1.14-4.fc15.i686
libtiff-3.9.5-3.fc17.x86_64 is a duplicate with libtiff-3.9.5-3.fc16.i686
libtool-ltdl-2.4.2-3.fc17.x86_64 is a duplicate with libtool-ltdl-2.4-9.fc16.i686
1:libusb-0.1.3-10.fc17.x86_64 is a duplicate with 1:libusb-0.1.3-9.fc16.i686
libusb1-1.0.9-0.6.rc1.fc17.x86_64 is a duplicate with libusb1-1.0.9-0.6.rc1.fc16.i686
libuuid-2.21.1-1.fc17.x86_64 is a duplicate with libuuid-2.20.1-2.3.fc16.i686
libv4l-0.8.7-1.fc17.x86_64 is a duplicate with libv4l-0.8.7-1.fc16.i686
1:libvorbis-1.3.3-1.fc17.x86_64 is a duplicate with 1:libvorbis-1.3.3-1.fc16.i686
libxcb-1.8-2.fc17.x86_64 is a duplicate with libxcb-1.7-3.fc16.i686
libxml2-2.7.8-7.fc17.x86_64 is a duplicate with libxml2-2.7.8-6.fc16.i686
libxslt-1.1.26-9.fc17.x86_64 is a duplicate with libxslt-1.1.26-8.fc16.i686
llvm-libs-3.0-12.fc17.x86_64 is a duplicate with llvm-libs-2.9-10.fc16.i686
mesa-dri-drivers-7.11.2-3.fc16.i686 has missing requires of mesa-dri-filesystem(x86-32)
mesa-dri-drivers-8.0.2-8.fc17.x86_64 is a duplicate with mesa-dri-drivers-7.11.2-3.fc16.i686
mesa-libGL-8.0.2-8.fc17.x86_64 is a duplicate with mesa-libGL-7.11.2-3.fc16.i686
mesa-libGLU-8.0.2-8.fc17.x86_64 is a duplicate with mesa-libGLU-7.11.2-3.fc16.i686
ncurses-libs-5.9-2.20110716.fc16.i686 has missing requires of ncurses-base = ('0', '5.9', '2.20110716.fc16')
ncurses-libs-5.9-4.20120204.fc17.x86_64 is a duplicate with ncurses-libs-5.9-2.20110716.fc16.i686
nspr-4.9-2.fc17.x86_64 is a duplicate with nspr-4.9-2.fc16.i686
nss-3.13.4-3.fc17.x86_64 is a duplicate with nss-3.13.4-2.fc16.i686
nss-softokn-3.13.4-2.fc17.x86_64 is a duplicate with nss-softokn-3.13.4-1.fc16.i686
nss-softokn-freebl-3.13.4-2.fc17.x86_64 is a duplicate with nss-softokn-freebl-3.13.4-1.fc16.i686
nss-util-3.13.4-2.fc17.x86_64 is a duplicate with nss-util-3.13.4-2.fc16.i686
1:openssl-1.0.0i-1.fc17.x86_64 is a duplicate with openssl-1.0.0i-1.fc16.i686
p11-kit-0.12-1.fc17.x86_64 is a duplicate with p11-kit-0.6-1.fc16.i686
pam-1.1.5-5.fc17.x86_64 is a duplicate with pam-1.1.5-5.fc16.i686
pango-1.30.0-1.fc17.x86_64 is a duplicate with pango-1.29.4-1.fc16.i686
pdf2djvu-0.7.4-10.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
pdf2svg-0.2.1-15.fc16.x86_64 has missing requires of libpoppler.so.18()(64bit)
pidgin-2.10.2-1.fc16.x86_64 has missing requires of libgstfarsight-0.10.so.0()(64bit)
pidgin-2.10.2-1.fc16.x86_64 has missing requires of libpurple(x86-64) = ('0', '2.10.2', '1.fc16')
pidgin-evolution-2.10.2-1.fc16.x86_64 has missing requires of libcamel-1.2.so.29()(64bit)
pidgin-evolution-2.10.2-1.fc16.x86_64 has missing requires of libebook-1.2.so.12()(64bit)
pidgin-evolution-2.10.2-1.fc16.x86_64 has missing requires of libedata-book-1.2.so.11()(64bit)
pidgin-evolution-2.10.2-1.fc16.x86_64 has missing requires of libedataserver-1.2.so.15()(64bit)
pixman-0.24.4-2.fc17.x86_64 is a duplicate with pixman-0.24.4-1.fc16.i686
policycoreutils-gui-2.1.4-13.fc16.x86_64 has missing requires of policycoreutils-python = ('0', '2.1.4', '13.fc16')
pulseaudio-libs-1.1-9.fc17.x86_64 is a duplicate with pulseaudio-libs-0.9.23-1.fc16.i686
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of libpulsecommon-0.9.23.so()(64bit)
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of libpulsecore-0.9.23.so()(64bit)
pulseaudio-module-gconf-0.9.23-1.fc16.x86_64 has missing requires of pulseaudio = ('0', '0.9.23', '1.fc16')
pyclutter-1.3.2-2.fc15.x86_64 has missing requires of libclutter-glx-1.0.so.0()(64bit)
python-caribou-0.4.1-3.fc16.noarch has missing requires of caribou = ('0', '0.4.1', '3.fc16')
1:qt-4.8.1-10.fc17.x86_64 is a duplicate with 1:qt-4.8.1-5.fc16.i686
1:qt-x11-4.8.1-10.fc17.x86_64 is a duplicate with 1:qt-x11-4.8.1-5.fc16.i686
readline-6.2-4.fc17.x86_64 is a duplicate with readline-6.2-2.fc16.i686
setools-console-3.3.7-19.fc16.x86_64 has missing requires of setools-libs = ('0', '3.3.7', '19.fc16')
spice-gtk-0.11-4.fc16.x86_64 has missing requires of spice-glib(x86-64) = ('0', '0.11', '4.fc16')
sqlite-3.7.11-2.fc17.x86_64 is a duplicate with sqlite-3.7.7.1-1.fc16.i686
sssd-1.8.3-11.fc16.x86_64 has missing requires of libldb = ('0', '1.1.0', None)
tcp_wrappers-libs-7.6-69.fc17.x86_64 is a duplicate with tcp_wrappers-libs-7.6-64.fc16.i686
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12()(64bit)
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
vcdimager-0.7.24-1.fc15.x86_64 has missing requires of libiso9660.so.7()(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12()(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
vcdimager-libs-0.7.24-1.fc15.x86_64 has missing requires of libiso9660.so.7()(64bit)
2:vim-enhanced-7.3.515-1.fc16.x86_64 has missing requires of libruby.so.1.8()(64bit)
xcb-util-0.3.8-2.fc17.x86_64 is a duplicate with xcb-util-0.3.6-2.fc15.i686
xine-lib-extras-freeworld-1.1.20.1-1.fc16.x86_64 has missing requires of libcdio.so.12()(64bit)
xine-lib-extras-freeworld-1.1.20.1-1.fc16.x86_64 has missing requires of libcdio.so.12(CDIO_12)(64bit)
xine-lib-extras-freeworld-1.1.20.1-1.fc16.x86_64 has missing requires of libiso9660.so.7()(64bit)
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-acecad
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-aiptek
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-elographics
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-fpit
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-hyperpen
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-mutouch
xorg-x11-drivers-7.4-2.fc15.x86_64 has missing requires of xorg-x11-drv-penmount
xorg-x11-drv-apm-1.2.3-8.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-glint-1.2.5-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i128-1.3.4-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i740-1.3.2-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-nv-2.1.18-8.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-r128-6.8.1-11.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-savage-2.3.3-1.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sis-0.10.3-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-trident-1.3.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
zlib-1.2.5-6.fc17.x86_64 is a duplicate with zlib-1.2.5-6.fc16.i686
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-30.03-14.E2XZR3.yumtx


Expected results:

yum update command completes successfully.
Comment 1 Eugene Mah 2012-05-31 06:15:38 EDT
Ran into the same problem. cups-libs was updated to the F17 version and libcups.so.2 is located in /usr/lib64/

"Package 1:cups-libs-1.5.2-12.fc17.x86_64 already installed and latest version"
Comment 2 Eugene Mah 2012-05-31 08:47:44 EDT
(In reply to comment #1)
> Ran into the same problem. cups-libs was updated to the F17 version and
> libcups.so.2 is located in /usr/lib64/
> 
> "Package 1:cups-libs-1.5.2-12.fc17.x86_64 already installed and latest
> version"

removing the 32 bit version of gtk+ allowed the update to proceed on my system
Comment 3 Eugene Mah 2012-05-31 18:41:34 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Ran into the same problem. cups-libs was updated to the F17 version and
> > libcups.so.2 is located in /usr/lib64/
> > 
> > "Package 1:cups-libs-1.5.2-12.fc17.x86_64 already installed and latest
> > version"
> 
> removing the 32 bit version of gtk+ allowed the update to proceed on my
> system

bah. gtk2, not gtk+
Comment 4 Ray Beckler 2012-06-02 03:01:30 EDT
I'm experiencing the exact same issue. Excluding mesa from the update then causes  Netbeans and qmmp-plugins to fail, excluding those creates other issues.

"ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
libcups.so.2 is needed by gtk2-2.24.10-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum"
Comment 5 Grzegorz Witkowski 2012-06-04 14:50:37 EDT
32bit gtk2/mesa-dri are the reason. Remove them and update manually everything else and the issue is fixed.
Comment 6 Ray Beckler 2012-06-04 20:21:02 EDT
That worked.  I'd tried it before but hadn't noticed the "only native software" filter was active.  Duh.

Note You need to log in before you can comment on or make changes to this bug.