This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 826334 - [Hitachi 3.1 FEAT] Support persistent hugepage with RHEV
[Hitachi 3.1 FEAT] Support persistent hugepage with RHEV
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.1.0
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Doron Fediuck
Yaniv Kaul
sla
: FutureFeature
Depends On:
Blocks: 826359
  Show dependency treegraph
 
Reported: 2012-05-29 23:10 EDT by Satoru Moriya
Modified: 2016-02-10 15:19 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 05:35:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satoru Moriya 2012-05-29 23:10:31 EDT
1. Feature Overview:
   a) Name of feature:
      Support persistent hugepage with RHEV

   b) Feature Description:
      persistent hugepage (hugetlb) support with RHEV.

      With this feature, we can mount hugetlbfs, reserve hugepages,
      exec qemu-kvm with hugetlbfs from RHEV manager.

2. Feature Details:
   a) Architectures:
         32-bit x86
         64-bit Intel EM64T/AMD64

   b) Bugzilla Dependencies:
      None

   c) Drivers or hardware dependencies:
      None

   d) Upstream acceptance information:
      None

   e) External links:
      None

   f) Severity (H,M,L):
      High

   g) Feature Needed by:
      2013 2Q
Comment 1 Satoru Moriya 2012-05-29 23:18:16 EDT
3. Business Justification:
   a) Why is this feature needed?
      Using persistent hugepage in virtualized environment provides
      guest with better performance.

      Also, using hugepage implies that pages which guest uses are
      never reclaimed/swapped out. That is important to stabilize
      guest performance and keep user's SLA.

   b) What hardware does this enable?
      None.

   c) Business impact?
      This is one of the fundamental features which a vitualization
      platform must have.

   d) Other business drivers:
      None.


4. Primary contact at Red Hat, email, phone (chat)
      Name : Larry Troan
      Email: ltroan@redhat.com
      Phone: 919-754-4196

5. Primary contact at Partner, email, phone (chat)
      Name : Satoru Moriya
      Email: smoriya@redhat.com
      Phone: 978-392-2418
Comment 2 Satoru Moriya 2012-05-29 23:19:27 EDT
I just choose distribution for component because I have no idea which component I should choose.

Please change it to appropriate component.
Comment 3 Andrew Cathrow 2012-05-30 07:10:03 EDT
what is the advantage of using huge pages rather than transparent huge pages?
The performance difference is very low but the implications of overhead of static huge pages are significant. Using static huge pages it's easy to get into situations where we don't have enough huge pages but have enough regular pages and vice versa, also after running an environment where VMs start and stop we could get into a situation where memory is "fragmented" and we don't have enough contiguous blocks of memory to run VMs.
Using THP also prevents use of KSM.

If we can prevent the host from swapping (3a) then what is the need for static huge pages?
Comment 5 Satoru Moriya 2012-06-01 13:14:20 EDT
(In reply to comment #3)
> what is the advantage of using huge pages rather than transparent huge pages?
> The performance difference is very low but the implications of overhead of
> static huge pages are significant. Using static huge pages it's easy to get
> into situations where we don't have enough huge pages but have enough
> regular pages and vice versa, also after running an environment where VMs
> start and stop we could get into a situation where memory is "fragmented"
> and we don't have enough contiguous blocks of memory to run VMs.
> Using THP also prevents use of KSM.

You're right.
 
> If we can prevent the host from swapping (3a) then what is the need for
> static huge pages?

The biggest advantage of using hugepage rather than THP is that we can
avoid swapout, I think.

So if we can avoid swapping with THP, static hugepage doesn't have an
advantage except small performance improvement.
Comment 6 Andrew Cathrow 2012-07-11 05:35:17 EDT
This isn't something that we can commit to in 3.1. It is unlikely we can in 4.0 due to the complexities of managing memory this in a dynamic environment.

However a user can accomplish this with Hooks, we already have a VDSM hook for this feature.

http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=tree;f=vdsm_hooks/hugepages;h=3c3dd55a7f18fcbf9533c777f7f4f26e901072af;hb=ae38d3e8c7e2edceb42ecced00512026971d779c

Note You need to log in before you can comment on or make changes to this bug.