This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 826335 - Preupgrade fully updated F16->F17; Unhandled exception error upon reboot
Preupgrade fully updated F16->F17; Unhandled exception error upon reboot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 23:17 EDT by Gireesh K. Bhat
Modified: 2013-07-31 20:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 20:41:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gireesh K. Bhat 2012-05-29 23:17:20 EDT
Description of problem:
Using preupgrade to upgrade from a fully updated F16 to F17 causes an "Unhandled exception error" when scanning the partitions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Invoke preupgrade from a fully updated F16 system
2. When prompted to reboot do so. 
3. Boot into upgrade grub entry
  
Actual results:
Unhandled exception error

Expected results:
Continued upgrade

Additional info:
Fresh install from live CD worked without issues using same partition table.
Comment 1 demmo 2012-08-11 03:43:20 EDT
Is there a fix for the problem ? I can't use Live CD because the new install will erase all my data.
Comment 2 Paul Budnik 2012-11-22 00:25:18 EST
I had the same problem. I used preupgrade on a fully updated fedora 16 system and ran into the boot partition too small problem. I continued with preupgrade to the reboot prompt. Preupgrade failed to reboot (a documented bug related to the boot partition too small). I then went to the full X86_64 Fedora install disk to update Fedora16. In scanning the partitions I got the unhandled exception problem. I eventually found a fix for the failure to reboot from preupgrade problem. I deleted "LiveOS/squashfs.img" from the end of a line in the grub menu. I ran preupgrade again and this time the reboot worked. The file squashfs.img was downloaded as part of the reboot. The reboot continued and began scanning partitions. Then I got an unhandled exception.
Comment 3 Paul Budnik 2012-11-23 13:00:01 EST
I managed to get past the unhandled exception by reading more of the debugging information. I had two iso files mounted at boot time as simulated CDs and that was apparently what caused the unhandled exception. I commented out those lines in /etc/fstab and then restarted the installation upgrade from the full DVD. This completed normally with an operable system that has its own problems.
Comment 4 Fedora End Of Life 2013-07-03 18:39:44 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 20:41:21 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.