Bug 826390 - cannot restore snapshot for scalable app on integration env
cannot restore snapshot for scalable app on integration env
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 02:22 EDT by Meng Bo
Modified: 2015-05-14 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-30 02:22:00 EDT
Description of problem:
create scalable app, take snapshot for it , after that try to restore the snapshot to the same app will get failure.

Version-Release number of selected component (if applicable):
int.openshift.redhat.com

How reproducible:
always

Steps to Reproduce:
1.create scalable app
rhc app create -a perl1s -t perl-5.10 -s -d 
2.take snapshot 
rhc app snapshot save -a perl1s
3.restore snapshot 
rhc app snapshot restore -a perl1s
  
Actual results:
snapshot restore failed with exit code 1

Expected results:
snapshot should be restored successfully.

Additional info:
this issue cannot be reproduced on both devenv_1806 and devenv_1808


[root@localhost openshifttestdir]# rhc app snapshot restore -a perl1s 
Password: ******

Restoring from snapshot perl1s.tar.gz...

Stopping application...
Done
Removing old git repo: ~/git/perl1s.git/
Removing old data dir: ~/perl1s/app/data/*
Restoring ~/git/perl1s.git and ~/app/data
~ ~
fatal: not a tree object
tar: 
This does not look like a tar archive

tar: 
Exiting with failure status due to previous errors

~
SSH_CMD: ssh f8ffcefd3868430794f60754e95c93fb@10.98.175.175
++ date
+ echo 'Syncing to gear: f8ffcefd3868430794f60754e95c93fb@10.98.175.175:f8ffcefd38 @ ' Wed May 30 02:14:07 EDT 2012
Syncing to gear: f8ffcefd3868430794f60754e95c93fb@10.98.175.175:f8ffcefd38 @  Wed May 30 02:14:07 EDT 2012
+ for rpccall in '"${OPENSHIFT_SYNC_GEARS_PRE[@]}"'
+ ssh f8ffcefd3868430794f60754e95c93fb@10.98.175.175 'ctl_all stop'

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app destroy'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

WARNING: This ssh terminal was started without a tty.
          It is highly recommended to login with: ssh -t
+ /var/lib/stickshift/f8ffcefd3868430794f60754e95c93fb/perl-5.10/f8ffcefd38_ctl.sh stop
Syntax error on line 2 of /var/lib/stickshift/f8ffcefd3868430794f60754e95c93fb/f8ffcefd38/conf.d/stickshift.conf:
DocumentRoot must be a directory
httpd (no pid file) not running
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//repo ']'
+ rsync -v --delete-after -az /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//repo/ f8ffcefd3868430794f60754e95c93fb@10.98.175.175:f8ffcefd38/repo/
building file list ... done

sent 102 bytes  received 12 bytes  76.00 bytes/sec
total size is 0  speedup is 0.00
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//node_modules ']'
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//virtenv ']'
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//../.m2 ']'
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//.openshift ']'
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//deployments ']'
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//perl5lib ']'
+ rsync -v --delete-after -az /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//perl5lib/ f8ffcefd3868430794f60754e95c93fb@10.98.175.175:f8ffcefd38/perl5lib/
building file list ... done

sent 102 bytes  received 12 bytes  228.00 bytes/sec
total size is 0  speedup is 0.00
+ for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
+ '[' -d /var/lib/stickshift/3ba59f650ec649cbbae4f239314ec330/perl1s//phplib ']'
+ for rpccall in '"${OPENSHIFT_SYNC_GEARS_POST[@]}"'
+ ssh f8ffcefd3868430794f60754e95c93fb@10.98.175.175 deploy.sh
+ for rpccall in '"${OPENSHIFT_SYNC_GEARS_POST[@]}"'
+ ssh f8ffcefd3868430794f60754e95c93fb@10.98.175.175 'ctl_all start'

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app destroy'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

WARNING: This ssh terminal was started without a tty.
          It is highly recommended to login with: ssh -t
+ /var/lib/stickshift/f8ffcefd3868430794f60754e95c93fb/perl-5.10/f8ffcefd38_ctl.sh start
Syntax error on line 2 of /var/lib/stickshift/f8ffcefd3868430794f60754e95c93fb/perl-5.10/conf.d/stickshift.conf:
DocumentRoot must be a directory
Exit code: 1
Starting application...
Done
Terminating...
Comment 1 Rob Millner 2012-05-30 14:51:48 EDT
Can't reproduce on devenv or INT.  Some fixes have gone into both the rhc tools and devenv related to snapshot and restore over the past few days; this may have been resolved.

Passing back to Q/E to see if it can be reproduced.
Comment 2 Meng Bo 2012-05-31 03:44:40 EDT
Checked on devenv_1809 with integration enabled.
Issue cannot be reproduced.
Mark bug as verified.

Note You need to log in before you can comment on or make changes to this bug.