Bug 82642 - euro symbol doesn't work
euro symbol doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-24 07:41 EST by Marius Andreiana
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 06:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2003-01-24 07:41:27 EST
euro symbol ( defined with EuroSign ) doesn't work anymore in phoebe2, I get the
old key instead.

This is also reported here by somebody else
https://listman.redhat.com/pipermail/phoebe-list/2003-January/000721.html
Comment 1 Mike A. Harris 2003-01-24 09:26:11 EST
That is dependant on the locale and keyboard settings you are using.
The euro doesn't exist in all locales, nor all keyboard layouts.  Please
indicate which LANG setting and keyboard mapping you are using.
Comment 2 Marius Andreiana 2003-01-24 10:40:24 EST
What I use (ro) it's not in XFree86 cvs yet, so let's take 'fr' for example.
I haven't tested it on phoebe2, but should behave the same. So
setxkbmap fr
press right alt + e, euro key should be displayed.
But it seems it doesn't in phoebe2.
Comment 3 Mike A. Harris 2003-01-25 15:30:41 EST
Ok, please report all of this information directly to xfree86@xfree86.org
where the people who are experts on these types of matters can address
the issue as soon as possible.

When fixes have been incorporated into the XFree86 CVS sources, they will
be picked up by me in a future package update.
Comment 4 Mike A. Harris 2003-02-01 21:08:47 EST
I'm assuming you've reported this issue upstream to xfree86@xfree86.org
as requested above and resolving this issue as UPSTREAM for now.  When
the problem is fixed by upstream developers, we'll pick up the fixes in
a code update.
Comment 5 Marius Andreiana 2003-02-02 12:04:43 EST
Yes, I've reported there, got one replay which said worksforme.
I'll try again in the next beta. Thanks
Comment 6 Michael Schwendt 2003-02-02 12:59:24 EST
What's the exact test case and test environment here?

I cannot reproduce it with LANG="de_DE.UTF-8" and gnome-terminal or konsole and
KDE, default Xmodmap.

But in xterm, AltGr+E prints a blank character instead of the Euro symbol, even
with an ISO Latin-15 font. AltGr+C gives a Cent symbol (as a side-note for
hair-splitters, Euro Cent doesn't have a special symbol, this was an unrelated
test ;).
Comment 7 Michael Schwendt 2003-02-02 13:12:22 EST
And what's this? Long since I've used tcsh the last time. Pressing AltGr+E in
tcsh gives " ??" instead of the Euro symbol (tested in GNOME).

$ gnome-terminal -e tcsh
$ set | grep ver
version tcsh 6.12.00 (Astron) 2002-07-23 (i386-intel-linux) options
8b,nls,dl,al,kan,rh,color,dspm,filec
$  ?? ?? ?? ?? ?? ?
Comment 8 Marius Andreiana 2003-02-05 09:10:22 EST
With de_DE.UTF-8, the euro symbol works in gedit and open office, but not in
gnome-terminal ( displays letter e ) and xterm ( displays blank ).

With ro_RO.UTF-8 it doesn't work at all ( the xbk symbols file with euro it's
not in cvs yet, I'm testing with it ). The same file used to work on redhat 8.0
Comment 9 Mike A. Harris 2003-04-25 06:20:39 EDT
Is this still a problem in 4.3.0 in RHL 9?  If so, please report this in
upstream bugzilla, and provide the URL here and I will track it.
Comment 10 Mike A. Harris 2003-07-17 06:12:57 EDT
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:

    http://bugs.xfree86.org

Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.


Note You need to log in before you can comment on or make changes to this bug.