Bug 826447 - scaled-up gear infomation will not be added to gear-registry.db for scalable app with mongodb/mysql embedded
scaled-up gear infomation will not be added to gear-registry.db for scalable ...
Status: CLOSED DUPLICATE of bug 826464
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 04:35 EDT by Meng Bo
Modified: 2015-05-14 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 13:04:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-30 04:35:36 EDT
Description of problem:
scale-up scalable app with mongodb/mysql embedded, check /haproxy-status/ page for gear infomation, will not find the new added gear, and ssh login to the app to check ~/haproxy-1.4/conf/gear-registry.db will not find the new added gear info.

Version-Release number of selected component (if applicable):
cartridge-haproxy-1.4-0.10.7-1.el6_2.noarch
devenv_1808
int.openshift.redhat.com

How reproducible:
always

Steps to Reproduce:
1.create scalable app
2.embed mongodb/mysql to it
3.scale-up the app via REST API
4.check the /haproxy-status/ page via browser
5.check the ~/haproxy-1.4/conf/gear-registry.db file via ssh
  
Actual results:
4.the new added gear info will not show in /haproxy-status/ page
5.the new added gear info will not show in gear-registry.db

Expected results:
they should be

Additional info:
the new added gear info will show in the two places for scalable app without cartridge embedded.
this issue cannot be reproduced on devenv_1806
you can find the gear directory has been created under /var/lib/stickshift
Comment 1 Ram Ranganathan 2012-05-30 13:04:20 EDT
This is not a bug -- the newly added gear for mysql will not show up in haproxy as that gear is not serving the application code. That new gear only has the data tier.
This needs a test case expected results update.

haproxy  config + gear registry for haproxy [rsync really to push newly deployed code] should only have the serving gears in it.
Comment 2 Ram Ranganathan 2012-05-30 13:28:58 EDT
Found out why the scaled up gear does not show up -- its because of the embed of mongo and mysql -- the env variables are messed up and sourcing those in fails. 
This bug is really a duplicate of the underlying issue in bugz 826464.

*** This bug has been marked as a duplicate of bug 826464 ***

Note You need to log in before you can comment on or make changes to this bug.