Bug 826510 - php-imap: Unable to create selectable TCP socket
php-imap: Unable to create selectable TCP socket
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libc-client (Show other bugs)
6.2
All Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Joe Orton
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 07:39 EDT by Jakub Jedelsky
Modified: 2014-10-30 19:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-30 19:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jedelsky 2012-05-30 07:39:50 EDT
Description of problem:
If we want to run simple PHP code with function imap_open() via Apache, it returns an error message (see Actual results). It happens when Apache has more than 1024 files (eg. logs) opened.

Version-Release number of selected component (if applicable):
php(-imap) 5.3.3-3.el6_2.8

How reproducible:
Allways, if Apache has more than 1024 files opened.

Steps to Reproduce:
1. Run Apache with a lot of logs or another files opened (more than 1024)
2. Run PHP script with imap_open()
  
Actual results:
Function imap_open() returns error: "Unable to create selectable TCP socket (1033 >= 1024)"

Expected results:
Can connect to IMAP server without any problems.

Additional info:
Error "Unable to create..." is part of libc-client package, which is used for php-imap build, so maube it's for its team.
Comment 2 Joe Orton 2012-05-30 08:50:53 EDT
Thanks for the report.  This is indeed a c-client bug, it is using select() rather than poll() and faces a 1024 fd limit.  It would be possible to work around this bug by using php out-of-process via CGI or FastCGI.
Comment 3 RHEL Product and Program Management 2012-07-10 04:31:10 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 20:00:08 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-09-07 01:35:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Joe Orton 2014-02-14 03:59:39 EST
If this issue is critical or in any way time sensitive, please raise a ticket
through your regular Red Hat support channels to make certain it receives the
proper attention and prioritization to assure a timely resolution.

For information on how to contact the Red Hat production support team, please
visit: https://www.redhat.com/support/process/production/#howto
Comment 9 RHEL Product and Program Management 2014-10-30 19:05:44 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.