This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 826524 - sesearch works but still prints WARNING message
sesearch works but still prints WARNING message
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Paris
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 08:21 EDT by Milos Malik
Modified: 2013-08-05 14:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 14:32:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-05-30 08:21:13 EDT
Description of problem:
What's the purpose of the WARNING message?

Version-Release number of selected component (if applicable):
setools-libs-3.3.7-22.el7.x86_64
setools-libs-tcl-3.3.7-22.el7.x86_64
setools-libs-python-3.3.7-22.el7.x86_64
setools-console-3.3.7-22.el7.x86_64
setools-3.3.7-22.el7.x86_64
setools-gui-3.3.7-22.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# sesearch --auditallow 1>/dev/null
WARNING: Policy would be downgraded from version 27 to 26.
# sesearch --neverallow 1>/dev/null
WARNING: Policy would be downgraded from version 27 to 26.
ERROR: Cannot get avrules: Neverallow rules requested but not available
# sesearch --allow 1>/dev/null
WARNING: Policy would be downgraded from version 27 to 26.
# sesearch --dontaudit 1>/dev/null
WARNING: Policy would be downgraded from version 27 to 26.
#
  
Actual results:
* WARNING message shows up

Expected results:
* WARNING message disappeared
Comment 1 Daniel Walsh 2012-05-30 09:27:51 EDT
We need to get an updated kernel that supports policy 27.
Comment 2 Eric Paris 2012-05-30 09:44:35 EDT
Should be fixed in the 3.5 kernels currently available in rawhide.  I'll try to figure out where RHEL7 is going to end up so I can figure out how to handle this bug.
Comment 4 Eric Paris 2013-08-05 14:32:53 EDT
RHEL7 uses a new enough kernel.

Note You need to log in before you can comment on or make changes to this bug.