Bug 826525 - [abrt] evolution-3.4.1-2.fc17: parse_message: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.1-2.fc17: parse_message: Process /usr/bin/evolution was ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:86aab5f569fb8a3e66f1f5e38aa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 08:26 EDT by arnav
Modified: 2012-06-11 03:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 08:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (20.26 KB, text/plain)
2012-05-30 08:26 EDT, arnav
no flags Details
File: maps (64.64 KB, text/plain)
2012-05-30 08:26 EDT, arnav
no flags Details
File: dso_list (8.92 KB, text/plain)
2012-05-30 08:26 EDT, arnav
no flags Details
File: build_ids (7.77 KB, text/plain)
2012-05-30 08:26 EDT, arnav
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 677264 None None None 2012-06-01 08:05:53 EDT

  None (edit)
Description arnav 2012-05-30 08:26:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
crash_function: parse_message
executable:     /usr/bin/evolution
kernel:         3.3.4-5.fc17.i686
pid:            2067
pwd:            /home/arnav
time:           Wed 30 May 2012 05:23:28 PM IST
uid:            1000
username:       arnav

backtrace:      Text file, 105867 bytes
build_ids:      Text file, 7954 bytes
core_backtrace: Text file, 8838 bytes
dso_list:       Text file, 9139 bytes
event_log:      Text file, 20749 bytes
maps:           Text file, 66195 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/arnav/2

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=2
:HOSTNAME=fedora.lenovo
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/arnav/keyring-xNd8bm
:IMSETTINGS_MODULE=none
:USER=arnav
:USERNAME=arnav
:MAIL=/var/spool/mail/arnav
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/arnav/.local/bin:/home/arnav/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/arnav
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=972
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/arnav
:SHLVL=1
:LOGNAME=arnav
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-1sU3rEEh59,guid=66eee7d1b63e2f90f31d973900000457
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/arnav
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-arnav-LxqMy5/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/976,unix/unix:/tmp/.ICE-unix/976
:SSH_AUTH_SOCK=/run/user/arnav/keyring-xNd8bm/ssh
:GPG_AGENT_INFO=/run/user/arnav/keyring-xNd8bm/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2067
:DESKTOP_STARTUP_ID=gnome-shell-1187-fedora.lenovo-evolution-5_TIME1921647

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15923                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15923                15923                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/arnav/.xsession-errors
:pos:	17850
:flags:	02002
:2:/home/arnav/.xsession-errors
:pos:	17850
:flags:	02002
:3:socket:[33908]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[33911]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[32660]
:pos:	0
:flags:	02004002
:8:socket:[33102]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[33914]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:/home/arnav/.local/share/evolution/mail/local/folders.db
:pos:	40
:flags:	02100002
:13:/home/arnav/.pki/nssdb/cert9.db
:pos:	40
:flags:	02100002
:14:/home/arnav/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:15:/var/tmp/etilqs_ncw7fuX20VGIxtu (deleted)
:pos:	28
:flags:	02100002
:16:/var/tmp/etilqs_CuCvO95xeUKPOxA (deleted)
:pos:	2056
:flags:	02500002
:17:/var/tmp/etilqs_V9muJ9QsqenTOap (deleted)
:pos:	2048
:flags:	02500002
:18:/etc/pki/nssdb/cert9.db
:pos:	40
:flags:	02100000
:19:/var/tmp/etilqs_WNV1Utvq3fxMFmn (deleted)
:pos:	28
:flags:	02100002
:20:/var/tmp/etilqs_uC5IDOGC1Q27qDN (deleted)
:pos:	2056
:flags:	02500002
:21:/var/tmp/etilqs_7QQ9KitmDGhtivl (deleted)
:pos:	2048
:flags:	02500002
:22:/var/tmp/etilqs_fMFekwleO10VAP2 (deleted)
:pos:	28
:flags:	02100002
:23:/var/tmp/etilqs_z6nf6hB5ZIEHNbZ (deleted)
:pos:	2048
:flags:	02500002
:24:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:25:/var/tmp/etilqs_zP6dmdf4tjzdGMu (deleted)
:pos:	28
:flags:	02100002
:26:/var/tmp/etilqs_cPIjiP2aRBk8cFH (deleted)
:pos:	2048
:flags:	02500002
:27:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:28:/home/arnav/.local/share/evolution/mail/local/..ibex.index
:pos:	1024
:flags:	0100002
:29:/home/arnav/.local/share/evolution/mail/local/..ibex.index.data
:pos:	0
:flags:	0102002
:30:/home/arnav/.local/share/evolution/mail/local/.Drafts.ibex.index
:pos:	6144
:flags:	0100002
:31:/home/arnav/.local/share/evolution/mail/local/.Drafts.ibex.index.data
:pos:	0
:flags:	0102002
:32:/home/arnav/.local/share/evolution/mail/local/.Outbox.ibex.index
:pos:	6144
:flags:	0100002
:33:/home/arnav/.local/share/evolution/mail/local/.Outbox.ibex.index.data
:pos:	0
:flags:	0102002
:34:/home/arnav/.local/share/evolution/mail/local/.Sent.ibex.index
:pos:	6144
:flags:	0100002
:35:/home/arnav/.local/share/evolution/mail/local/.Sent.ibex.index.data
:pos:	0
:flags:	0102002
:36:/home/arnav/.local/share/evolution/mail/local/.Templates.ibex.index
:pos:	6144
:flags:	0100002
:37:/home/arnav/.local/share/evolution/mail/local/.Templates.ibex.index.data
:pos:	0
:flags:	0102002
:38:/home/arnav/.local/share/evolution/mail/vfolder/folders.db
:pos:	3072
:flags:	02100002
:39:socket:[33121]
:pos:	0
:flags:	02004002
:40:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:41:/var/tmp/etilqs_4opJupkoPIG0Jp4 (deleted)
:pos:	28
:flags:	02100002
:42:/home/arnav/.cache/evolution/mail/1338378634.2067.21@fedora.lenovo/folders.db
:pos:	4559872
:flags:	02100002
:43:socket:[32750]
:pos:	0
:flags:	04002
:44:anon_inode:inotify
:pos:	0
:flags:	02004000
:45:/var/tmp/etilqs_bqQfdXqiSo3P1et (deleted)
:pos:	3084
:flags:	02500002
:46:/var/tmp/etilqs_OTu39aXwllwxILl (deleted)
:pos:	3072
:flags:	02500002
:47:socket:[36643]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 9656dde1-0869-4965-90f3-bdff88409b34
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3325.03
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Atom(TM) CPU N570   @ 1.66GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 28
:Number of CPUs: 4
:CPU Speed: 1667
:System Memory: 2006
:System Swap: 4031
:Vendor: LENOVO
:System: 20109 Ideapad S100
:Form factor: Notebook
:Kernel: 3.3.4-5.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10172:6058:14613) pci, None, PCI/ISA, NM10 Family LPC Controller
:(4332:33142:4332:37270) pci, rtl8192ce, NETWORK, RTL8188CE 802.11b/g/n WiFi Adapter
:(32902:40977:6058:14600) pci, i915, VIDEO, N10 Family Integrated Graphics Controller
:(32902:40978:6058:14600) pci, None, VIDEO, N10 Family Integrated Graphics Controller
:(32902:10192:6058:14603) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:6058:14604) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(4332:33078:6058:14630) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10200:6058:14602) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:6058:14616) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:6058:14612) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10177:6058:14615) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:10185:6058:14608) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:6058:14607) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:40976:6058:14599) pci, agpgart-intel, HOST/PCI, N10 Family DMI Bridge
:(32902:10186:6058:14609) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:6058:14610) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:6058:14611) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_fedora-lv_root / ext4 4096 4096 13092026 12027789 11896739 3276800 3152012 3152012
:/dev/sda1 /boot ext4 1024 1024 508745 427033 401433 128016 127668 127668
:/dev/mapper/vg_fedora-lv_home /home ext4 4096 4096 63798936 62799967 59606316 15974400 15973810 15973810
:

var_log_messages:
:May 30 17:23:27 fedora kernel: [ 2104.004504] evolution[2067]: segfault at c ip 05f7339d sp bfc21460 error 4 in libevolution-mail.so[5eec000+b8000]
:May 30 17:23:30 fedora abrt[5254]: Saved core dump of pid 2067 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-05-30-17:23:28-2067 (120184832 bytes)
Comment 1 arnav 2012-05-30 08:26:27 EDT
Created attachment 587710 [details]
File: core_backtrace
Comment 2 arnav 2012-05-30 08:26:30 EDT
Created attachment 587711 [details]
File: event_log
Comment 3 arnav 2012-05-30 08:26:35 EDT
Created attachment 587712 [details]
File: backtrace
Comment 4 arnav 2012-05-30 08:26:39 EDT
Created attachment 587713 [details]
File: maps
Comment 5 arnav 2012-05-30 08:26:42 EDT
Created attachment 587714 [details]
File: dso_list
Comment 6 arnav 2012-05-30 08:26:45 EDT
Created attachment 587715 [details]
File: build_ids
Comment 7 Milan Crha 2012-06-01 08:05:53 EDT
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=677264
Comment 8 Milan Crha 2012-06-05 08:45:59 EDT
Please see the associated upstream bug: I cannot reproduce the crash, it works fine for me. I suspect gmail.com server being either temporarily offline or the server address is redirected based on the callers world-wide-position, and the chosen server for the user returned broken data, which the evolution's code doesn't count with. But that's only a guess.
Comment 9 arnav 2012-06-05 09:10:33 EDT
I think this crash happened because i already had a gmail account configured and i tried to configue the same account again. But after that i have seen that when i use command line to close any program the system thinks it is a bug.
Comment 10 Milan Crha 2012-06-11 03:39:13 EDT
(In reply to comment #9)
> I think this crash happened because i already had a gmail account configured
> and i tried to configue the same account again. But after that i have seen
> that when i use command line to close any program the system thinks it is a
> bug.

Do you mean you "closed" evolution with 'kill' command,  'evolution --force-shutdown' or any similar command? If so, then I would say that I can close the upstream bug.

Note You need to log in before you can comment on or make changes to this bug.