Bug 826591 - Garbled console text on intel 82815
Garbled console text on intel 82815
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 10:54 EDT by Davide Repetto
Modified: 2013-02-22 18:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 18:52:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2012-05-30 10:54:44 EDT
Description of problem:
======================
Text on the console appears completely garbled immediately upon loading the kernel both with and without kernel-modesetting.

The vga is on an Intel desktop board:
====================================
        Manufacturer: Intel Corporation
        Product Name: (Fayetteville) D815EFVU
        Version: AAA51500-803

And is:
======
00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02)

Version-Release number of selected component (if applicable):
============================================================
Vanilla "desktop" install of Fedora 17 with kernel 3.3.7-1.fc17.i686.PAE

How reproducible:
================
Always

Additional info:
===============
It works perfectly with FC16 and kernel 3.3.7-1.fc16.i686 (and grub1)
Comment 1 Adam Jackson 2012-05-30 11:52:31 EDT
Despite being an Intel GPU there is currently no KMS support for 810/815 chips, so kernel modesetting isn't a factor here.

Do you still see this if you configure grub2 to boot with gfxpayload=text instead of gfxpayload=keep?
Comment 2 Davide Repetto 2012-05-30 15:58:57 EDT
Yes. It's the same with both parameters.
Comment 3 Davide Repetto 2013-02-22 18:52:30 EST
Pointless to keep the bug open. Most probably will be or is already fixed in new kernels. Besides, I have no way to verify it anymore, because the hardware is since gone in hardware heaven... :)
Comment 4 Davide Repetto 2013-02-22 18:53:03 EST
Pointless to keep the bug open. Most probably will be or is already fixed in new kernels. Besides, I have no way to verify it anymore, because the hardware is since gone in hardware heaven... :)

Note You need to log in before you can comment on or make changes to this bug.