Bug 826593 - [RHEVM] [backend] [Required Networks] VM migration algorithm doesn't include networks when it supplies the optional hosts for migration
[RHEVM] [backend] [Required Networks] VM migration algorithm doesn't include ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.0.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Laszlo Hornyak
Martin Pavlik
network sla
:
Depends On:
Blocks: 810675 830836 833648
  Show dependency treegraph
 
Reported: 2012-05-30 10:56 EDT by Martin Pavlik
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: si10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (15.75 KB, application/x-gzip)
2012-05-30 10:56 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-30 10:56:38 EDT
Created attachment 587763 [details]
vdsm.log + engine.log

Description of problem:
VM migration algorithm doesn't include networks when it supplies the optional hosts for migration

With introduction of new feature Required_Networks
(http://lists.ovirt.org/wiki/Features/Design/Network/Required_Networks) not all hosts in cluster have to have same set of networks, since some networks can be marked as non-required. 

This can lead to situation when VM migration will fail because user or rhevm will select for VM migration (VM is connected to non-required network) host without non-required network. 

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
Have 2 hosts (Host1, Host2)
1. Create logcial network and attach to cluster
2. configure new network as required=false
3. add network only to one host (Host1)
5. start VM on Host1
6. try to perform migration of VM from Host1 to Host2
  
Actual results:
in case VM is connected to non-required network all active hosts in cluster are offered for VM migration

Expected results:
in case VM is connected to non-required network all active hosts in cluster which contain non-required network are offered for VM migration


Additional info:

Thread-11477::ERROR::2012-05-30 16:50:09,569::vm::239::vm.Vm::(run) vmId=`e81eb68f-e3d6-471f-a003-c89118e97457`::Failed to migrate
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 222, in run
    self._startUnderlyingMigration()
  File "/usr/share/vdsm/libvirtvm.py", line 451, in _startUnderlyingMigration
    None, maxBandwidth)
  File "/usr/share/vdsm/libvirtvm.py", line 491, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/vdsm/libvirtconnection.py", line 82, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1100, in migrateToURI2
    if ret == -1: raise libvirtError ('virDomainMigrateToURI2() failed', dom=self)
libvirtError: Cannot get interface MTU on 'nonRequired': No such device
Comment 3 Laszlo Hornyak 2012-07-02 11:15:14 EDT
http://gerrit.ovirt.org/#/c/5838/
Comment 4 Laszlo Hornyak 2012-07-03 08:38:10 EDT
merged upstream

Note You need to log in before you can comment on or make changes to this bug.