Bug 826618 - systemd-udev in rawhide is not creating content in /run/udev with the correct label.
systemd-udev in rawhide is not creating content in /run/udev with the correct...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:43 EDT by Daniel Walsh
Modified: 2012-06-14 19:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: systemd-185-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 19:32:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2012-05-30 11:43:49 EDT
Description of problem:

When you boot an F18 box the content under /run/udev/ has lots of default_t labeled files instead of udev_var_run_t.

I believe these files are being created during early boot and not having their labels corrected, this works correctly in F17.

systemd-183-1.fc18.x86_64

This could be happening if the prefix is just being set to /dev and not to /var/run
Comment 1 Daniel Walsh 2012-05-30 11:55:23 EDT
The problem is caused by 

label_init("/dev")

We should either eliminate this since systemd-udev is creating content under /var/run also. (/run)

It really needs 

label_init("/dev", "/var/run")
Comment 2 Daniel Walsh 2012-05-30 12:10:31 EDT
Another option would be to only use the SELinux labeling rules in systemd-udev when creating content in /dev and rely on SELinux to label stuff created in other directories.
Comment 3 Kay Sievers 2012-05-30 15:03:01 EDT
Oh, I see. Yeah, that needs fixing.

How would "rely on SELinux to label stuff created in other directories"
look like? We do not have any explicit selinux context settings in other
paths than /dev.
Comment 4 Lennart Poettering 2012-05-30 20:01:56 EDT
Fixed in git.
Comment 5 Kay Sievers 2012-06-04 18:15:46 EDT
New release submitted for f18.
Comment 6 Daniel Walsh 2012-06-06 07:01:26 EDT
This one works for me.

Note You need to log in before you can comment on or make changes to this bug.