Bug 826620 - system-config-services tracebacks in Serbian locale
system-config-services tracebacks in Serbian locale
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-services (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Nils Philippsen
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:46 EDT by Petr Šplíchal
Modified: 2016-05-31 21:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-19 09:08:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2012-05-30 11:46:53 EDT
Description of problem:

When run under one of the following locales system-config-services
fails with a traceback:

sr_BA
sr_CS
sr

Version-Release number of selected component (if applicable):
system-config-services-0.99.45-1.el6.3.noarch

Steps to Reproduce:
LANG=sr_BA system-config-services
  
Actual results:
(process:21478): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
Traceback (most recent call last):
  File "/usr/sbin/system-config-services", line 109, in <module>
    class GUIServicesTreeView(gtk.TreeView):
  File "/usr/sbin/system-config-services", line 127, in GUIServicesTreeView
    SVC_COL_NAME: [_("Name"), gtk.CellRendererText, "text",
  File "/usr/sbin/system-config-services", line 39, in <lambda>
    _ = lambda x: gettext.ldgettext("system-config-services", x)
  File "/usr/lib64/python2.6/gettext.py", line 543, in ldgettext
    return t.lgettext(message)
  File "/usr/lib64/python2.6/gettext.py", line 368, in lgettext
    return tmsg.encode(locale.getpreferredencoding())
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-2: ordinal not in range(128)

Expected results:
GUI working.
Comment 1 RHEL Product and Program Management 2012-07-10 04:15:55 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:51:26 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 RHEL Product and Program Management 2012-09-07 01:31:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Nils Philippsen 2013-04-19 09:08:31 EDT
Closing as we don't support non-UTF8 locales for the Serbian language in Red Hat Enterprise Linux 6. I guess I could make it fail a little prettier but I don't think it's worth the effort, it would just replace the UnicodeEncodeError with a locale.Error unless much more effort is put into it.

Note You need to log in before you can comment on or make changes to this bug.