Bug 826627 - bind-9.9.0-4.fc17.x86_64 failed to start
bind-9.9.0-4.fc17.x86_64 failed to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 12:00 EDT by Artemy Kapitula, RCNTEC Ltd
Modified: 2013-04-30 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 12:50:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artemy Kapitula, RCNTEC Ltd 2012-05-30 12:00:42 EDT
Description of problem:

"named" service doesn't start on Fedora 17

Version-Release number of selected component (if applicable):

bind-9.9.0-4.fc17.x86_64

How reproducible:

Always.

Steps to Reproduce:

selinux is disabled
bind-chroot is not installed
Call "systemctl start named.service"
  
Actual results:

"systemctl start named.service" hangs, and after some waiting tells that service unit failed.
/var/log/messages contains the following message:

May 30 21:32:13 home systemd[1]: PID file /run/named/named.pid not readable (yet?) after start.
May 30 21:32:33 home named[4083]: shutting down
May 30 21:32:33 home named[4083]: stopping command channel on 127.0.0.1#953
May 30 21:32:33 home named[4083]: stopping command channel on ::1#953
May 30 21:32:33 home named[4083]: no longer listening on 127.0.0.1#53
May 30 21:32:33 home named[4083]: no longer listening on 192.168.1.2#53
May 30 21:32:33 home named[4083]: no longer listening on 192.168.66.1#53
May 30 21:32:33 home named[4083]: exiting

Expected results:

named should start and continue to run

Additional info:

I couldn't find directory /run/named, and systemd-tmpfiles --create ... doesn't help because /etc/tmpfiles.d/named has only one line: "d /var/run/named 0755 named named -"

named creates its' PID file as /var/run/named/named.pid by default (that's what "man named" told me) and the default /etc/named.conf doesn't have option "pid-file"

The solution was:

1. add "d /run/named 0755 named named -" into /etc/tmpfiles.d so it should be
d /var/run/named 0755 named named -
d /run/named 0755 named named -

2. add pid-file "/run/named.pid"; option into default named.conf
Comment 1 Artemy Kapitula, RCNTEC Ltd 2012-05-30 12:50:25 EDT
Ough, sorry that's not a bind bug!
Something goes wrong so /run and /var/run isn't the same after last update, that's more a systemd issue :-(

Note You need to log in before you can comment on or make changes to this bug.