Bug 826651 - Cannot log in to site with mocked streamline
Cannot log in to site with mocked streamline
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
urgent Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 13:14 EDT by Fotios Lindiakos
Modified: 2015-05-14 21:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fotios Lindiakos 2012-05-30 13:14:04 EDT
Description of problem:
When attempting to log into the site, the user is automatically logged out due to a bad cookie.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Attempt to login
2. Cry
  
Actual results:
Logged out immediately

Expected results:
Should be able to log in


Additional info:
I've tracked the issue down to escaping the login in lib/streamline/mock.rb, but don't have time to fix it right now.
This paste shows the problem: http://pastebin.test.redhat.com/91029
Comment 1 Fabiano Franz 2012-05-30 15:54:56 EDT
Only on development, lowering severity.
Comment 2 Clayton Coleman 2012-06-04 01:12:38 EDT
Using Base64 (strict, so as not to have newlines) to encode instead of CGI (cookie decoding fail).
Comment 3 Xiaoli Tian 2012-06-05 06:07:47 EDT
Verified it on devenv_1815, try to login with user xtian+t100@redhat.com in a non-integrated env. login successfully.

Note You need to log in before you can comment on or make changes to this bug.