Bug 826670 - Transaction Check vs. depsolve error
Transaction Check vs. depsolve error
Status: CLOSED DUPLICATE of bug 880844
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 14:08 EDT by Darron C. Knutson
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 03:56:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darron C. Knutson 2012-05-30 14:08:52 EDT
Description of problem: After performing an upgrade install from Fedora 16 to Fedora 17, performing a yum update produced the following error message:
"ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
libcups.so.2 is needed by gtk2-2.24.10-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum"


Version-Release number of selected component (if applicable):
See Above


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lofton Alley 2012-09-26 12:19:58 EDT
I have the same issue, but with a different set of upgraded packages. Here is my cli output:


Running Transaction Check
ERROR with transaction check vs depsolve:
ruby-irb = 1.8.7.358-2.fc16 is needed by (installed) ruby-rdoc-1.8.7.358-2.fc16.noarch
rubygem-pango = 1.0.3-1.fc16 is needed by (installed) ruby-pango-1.0.3-1.fc16.x86_64
rubygem-cairo = 1.10.2-1.fc16 is needed by (installed) ruby-cairo-1.10.2-1.fc16.x86_64
rubygem-gtk2 = 1.0.3-2.fc16 is needed by (installed) ruby-gtk2-1.0.3-2.fc16.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum

So it doesn't seem to be the packages per se, rather something in the resolution is looking for an F16 version when what I have installed is the F17 version, Which is correct since I am running F17.
Comment 2 usajdfields 2013-02-07 20:39:59 EST
ERROR with transaction check vs depsolve:
kernel-uname-r = 2.6.35.13-91.fc14.x86_64 is needed by kmod-ndiswrapper-2.6.35.13-91.fc14.x86_64-1.56-1.fc14.4.x86_64
kernel-uname-r = 2.6.35.14-106.fc14.x86_64 is needed by kmod-ndiswrapper-2.6.35.14-106.fc14.x86_64-1.56-1.fc14.12.x86_64
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
Comment 3 Jan Zeleny 2013-02-08 03:56:03 EST

*** This bug has been marked as a duplicate of bug 880844 ***

Note You need to log in before you can comment on or make changes to this bug.