Bug 826756 - rhc app add-alias returns 400 error on success
rhc app add-alias returns 400 error on success
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 18:25 EDT by Jhon Honce
Modified: 2015-05-14 21:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jhon Honce 2012-05-30 18:25:06 EDT
Description of problem:
rhc app  add-alias returns 400 error on success

Version-Release number of selected component (if applicable):


How reproducible:
everytime 

Steps to Reproduce:
1. create domain
2. create application
3. create alias for application (rhc app  add-alias -a app001 --alias application1)
  
Actual results:
rhc app  add-alias -a app001 --alias application1
Password: *

Problem reported from server. Response code was 500.
Re-run with -d for more information.

RESULT:
Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.

[root@ip-10-110-95-134 ~]# rhc app  add-alias -a app001 --alias application1 -d
Password: *

Contacting https://localhost
Problem reported from server. Response code was 400.

DEBUG:


Exit Code: 1
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3

RESULT:
Alias 'application1' already exists for 'app001'


Expected results:
Either don't return error when successful. Or, don't create alias on failure.

Additional info:
Comment 1 Rob Millner 2012-05-30 19:33:01 EDT
This looks like a broker issue.
Comment 2 Jhon Honce 2012-05-30 20:16:31 EDT
launched new devenv-stage_197 and was not able to recreate problem.
Comment 3 Abhishek Gupta 2012-06-04 17:00:24 EDT
Seems like a duplicate of Bug 820337 that I had fixed in the last week.
Comment 4 yquan 2012-06-05 01:14:31 EDT
It is fixed on devenv_1815.


Output:

[root@localhost ~]# rhc app add-alias -a php0 --alias application1
Password: **


RESULT:
Success

[root@localhost ~]# rhc domain show
Password: **


User Info
=========
Namespace: domaintest0005
  RHLogin: yquan@redhat.com


Application Info
================
php0
    Framework: php-5.3
     Creation: 2012-06-05T00:57:58-04:00
         UUID: 30f1202ae35c45a7a3016de0fe762cc2
      Git URL: ssh://30f1202ae35c45a7a3016de0fe762cc2@php0-domaintest0005.dev.rhcloud.com/~/git/php0.git/
   Public URL: http://php0-domaintest0005.dev.rhcloud.com/
      Aliases: application1

 Embedded: 
      mysql-5.1 - Connection URL: mysql://127.0.250.1:3306/

Note You need to log in before you can comment on or make changes to this bug.