Bug 826780 - package installs /var/run/setroubleshoot directory
package installs /var/run/setroubleshoot directory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 20:05 EDT by Peter Backes
Modified: 2013-01-28 15:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-28 15:23:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Backes 2012-05-30 20:05:23 EDT
Description of problem:
/var/run is a symlink to /run, which is mounted as tmpfs on systemd. rpms shouldn't reference files there

Version-Release number of selected component (if applicable):
setroubleshoot-server-3.1.11-1.fc17.i686
Comment 1 Daniel Walsh 2012-05-31 13:44:27 EDT
Is this a fedora decision or just your opinion?
Comment 2 Peter Backes 2012-05-31 14:44:30 EDT
(In reply to comment #1)
> Is this a fedora decision or just your opinion?

I don't understand what you mean ... I found the similar bug 748153 for a different package so I assumed it's a bug. To me, it seems not to make sense to include files in packages that would be stored on tmpfs? Perhaps together with %ghost, as discussed in bug 656638? But the package doesn't do that, either.
Comment 3 Daniel Walsh 2012-05-31 14:49:42 EDT
I think you will find lots of packages that include content in /var/run, perhaps because it was not always a tmpfs, but it also allows us to create the directory at install time, and with the correct label.

I was asking if there is a new directive within Fedora to remove /var/run and replace /run within spec files.  Or just to eliminate reference to /run directory.

On my f18 machine I see 48 files/dir in /var/run owned by packages.

 rpm -qf /var/run/*| grep -v owned | wc -l
46

Maybe some of these are ghosts.

Could you send a note to fedora-devel with a suggestion to remove these, and see what people say.
Comment 4 Peter Backes 2012-05-31 15:19:06 EDT
(In reply to comment #3)
> I was asking if there is a new directive within Fedora to remove /var/run
> and replace /run within spec files.  Or just to eliminate reference to /run
> directory.

Ah, ok. Sorry. I didn't want to suggest that /var/run should be replaced by /run. I wanted to stress that anything you place inside /var/run will ultimately be stored on a tmpfs. So just ignore the "/var/run is a symlink to /run" part.

Given bug 656638, I suppose the official directive is to include such files, but with %ghost?

> I think you will find lots of packages that include content in /var/run,
> perhaps because it was not always a tmpfs, but it also allows us to create
> the directory at install time, and with the correct label.

Yes, but it will be gone after the next reboot, so it's pretty pointless.

> Could you send a note to fedora-devel with a suggestion to remove these, and
> see what people say.

Bug 656638 ("mass bug filing") seems to imply that this has been discussed alreay. Perhaps you should better ask Lennart Poettering about it. I added him to CC.
Comment 5 Peter Backes 2012-05-31 15:48:08 EDT
Ah I now see that according to bug 656688, %ghost should already be in place. Well, anyway, I noticed that rpm -Va reports /var/run/setroubleshoot as missing on my system. Is this directory actually needed as a runtime directory, or is it created only as a temp directory? Does it use this directory at all?
Comment 6 Daniel Walsh 2012-05-31 16:15:41 EDT
Actually now that I look at it, we are no longer using /run/setroubleshoot or /var/log/setroubleshoot.

Fixed in setroubleshoot-3.1.12-1.fc17

Note You need to log in before you can comment on or make changes to this bug.