Bug 826847 - Network Manager dies at machine startup due to DBUS Exception
Network Manager dies at machine startup due to DBUS Exception
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-31 02:43 EDT by Jean-Paul Lambrechts
Modified: 2013-02-13 16:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-13 16:33:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Generated by Automatic Bug Reporting tool (7.84 KB, text/plain)
2012-05-31 02:43 EDT, Jean-Paul Lambrechts
no flags Details

  None (edit)
Description Jean-Paul Lambrechts 2012-05-31 02:43:57 EDT
Created attachment 587946 [details]
Generated by Automatic Bug Reporting tool

Description of problem:

Version-Release number of selected component (if applicable):NetworkManager 0.9.4-6.git20120521.fc16 x86_64 (Linux 3.3.7-1.fc16.x86_64 x86_64) KDE-4
Intel CPU Q6600 @ 2.40GHz 4 cores. Motherboard Asus "Stryker Extreme"

How reproducible: at every machine start (cold or warm start)

Steps to Reproduce:
1. just let it boot (autologin is enabled).
Actual results: consistent. Prevents from using NetworkManager to activate vpn connections

There is a work-around as explained below.

Expected results: wired and vpn connectins should be visible in the Network Manager "Connections" area shown by clicking on the NetworkManager icon (bottom bar on the screen)

Additional info: at computer start, Network Manager establishes the eth0 connection but shortly afterwards dies (does not show the wired and vpn connections anymore) because of a DBus exception. However eth0 is still active.
After logging out and logging in, Network Manager does not start. It shows a white "X" in a small red box on the bar at bottom of screen.
However, at that point, if unchecking the "enable network" (networkmanager icon in the bar at bottom of screen) and then
going to menu: Administration --> Service Management and (1) stopping Network Manager and then (2) starting Network Management, the  Network Manager works fine.

Another - different - x86_64 computer running exactly the same version of Fedora16 with current updates does not exhibit this failure.

Also, this issue is new: it did not happen before recent updates.
Comment 1 Rex Dieter 2012-05-31 08:52:41 EDT
you mention NM dies because of DBus exception.  What evidence do you have?  Any detail about the particular exception?
Comment 2 Rex Dieter 2012-05-31 08:55:45 EDT
OK, I see the attachment now,

:polkit.py:136:handle_authfail:DBusException: org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.services.manage: 

This is indeed an exception, but not enough evidence to conclude that NM is dead.

I'm guessing that combined with autologin, there's some sort of race condition.
Comment 3 Kevin Kofler 2012-05-31 09:01:53 EDT
Yet another duplicate of bug #820675?
Comment 4 Rex Dieter 2012-05-31 09:05:43 EDT
Probably not, this user is on f16 (not a f17 upgrade)
Comment 5 Jean-Paul Lambrechts 2012-05-31 12:01:46 EDT
Yes, it is f16.
If auto-login is disabled, NetworkManager fails to start automatically. In the plasmoid "Interfaces" area, there is a sentence: "NetworkManager is not running. Please start it."
Going to Administration --> Service Management, starting NetworkManager does not work. It is necessary to hit the stop button first, and then the start button to have it running.
Interestingly, in the same plasmoid window, the message "NetworkManager is not running. Please start it." is still displayed. However, NM is actually running because a vpn connection can be successfully activated in the plasmoid window.
Comment 6 Kevin Kofler 2012-05-31 12:16:17 EDT
The exception you're getting when trying to restart NM has nothing to do with NM at all, it comes from polkit when system-config-services tries to authorize the action of restarting a service. It doesn't even get as far as actually trying to start NM. (Try su -c "service NetworkManager start" in a terminal.)
Comment 7 Jean-Paul Lambrechts 2012-05-31 12:59:31 EDT
# Comment: this is with auto-login disabled and after logging in. Plasmoid window states:
# "NM is not running. Please start it."

[jlambrec@jlambrec-lnx ~]$ su -
[root@jlambrec-lnx ~]# service NetworkManager status
Redirecting to /bin/systemctl  status NetworkManager.service
NetworkManager.service - Network Manager
          Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
          Active: active (running) since Thu, 31 May 2012 09:44:01 -0700; 3min 29s ago
        Main PID: 1102 (NetworkManager)
          CGroup: name=systemd:/system/NetworkManager.service
                  ├ 1102 /usr/sbin/NetworkManager --no-daemon
                  └ 1229 /sbin/dhclient -d -4 -sf /usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-et...
# NM is still not running according to the plasmoid window
[root@jlambrec-lnx ~]# service NetworkManager start
Redirecting to /bin/systemctl  start NetworkManager.service
# NM is still not running according to the plasmoid window
[root@jlambrec-lnx ~]# service NetworkManager stop
Redirecting to /bin/systemctl  stop NetworkManager.service
# The system prompts for the root password here.
[root@jlambrec-lnx ~]# service NetworkManager start
Redirecting to /bin/systemctl  start NetworkManager.service
[root@jlambrec-lnx ~]# 
# NM is now running. Wired and vpn connections are now visible in the plasmoid window.
# However, under "Interfaces", it still states that NM is not running
[root@jlambrec-lnx ~]# service NetworkManager status
Redirecting to /bin/systemctl  status NetworkManager.service
NetworkManager.service - Network Manager
          Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
          Active: active (running) since Thu, 31 May 2012 09:48:17 -0700; 5min ago
        Main PID: 2101 (NetworkManager)
          CGroup: name=systemd:/system/NetworkManager.service
                  ├ 2101 /usr/sbin/NetworkManager --no-daemon
                  └ 2104 /sbin/dhclient -d -4 -sf /usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-et...
[root@jlambrec-lnx ~]#
Comment 8 Peter Levart 2012-06-07 12:58:52 EDT
The same behavior as Comment 7 also here. After boot and login, the NetworkManager process is running, but KDE applet shows as though it wasn't. Also, I only have a WiFi connection configured and it is not activated (as it should). After executing "systemctl restart NetworkManager.service" as root, the WiFi is activated and KDE applet starts to function normally.
Comment 9 Fedora End Of Life 2013-01-16 12:09:49 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 10 Fedora End Of Life 2013-02-13 16:33:34 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.