Bug 826856 - subscription-manager service-level --org=admin should say ""Error: --org is only applicable with --list"
subscription-manager service-level --org=admin should say ""Error: --org is o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-31 03:02 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-05-31 03:02:18 EDT
Description of problem:

subscription-manager service-level --org=admin should say "Error: --org is only applicable with --list"

Version-Release number of selected component (if applicable):
[root@dhcp201-111 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gnome-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-migration-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-firstboot-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-1.0.2-1.git.2.2b23e6e.el5


How reproducible:


Steps to Reproduce:
1.subscription-manager service-level --org=admin
2.
3.
  
Actual results:
Current service level: 

Expected results:
Error: --org is only applicable with --list

Additional info:
Comment 1 Bryan Kearney 2012-06-25 16:21:51 EDT
Adding the warning:

[root@bkearney yum.repos.d]# subscription-manager service-level --org admin
Error: --org is only supported with the --list command
Comment 2 Bryan Kearney 2012-06-26 20:25:59 EDT
fixed in master at 1e9f431513d1c49b1c400e67ebac40f1fb399bd7
Comment 3 RHEL Product and Program Management 2012-06-28 11:19:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Shwetha Kallesh 2012-07-02 05:10:57 EDT
Marking verified!

RPM version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-firstboot-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-migration-data-1.11.2.1-1.git.8.87961f3.el5
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5

[root@dhcp201-196 ~]# subscription-manager service-level --org admin
Error: --org is only supported with the --list command
Comment 6 errata-xmlrpc 2013-01-07 22:53:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.