Bug 826861 - [RHEVM] [GUI] Assign/Detach Networks dialog shows incorrect flags on networks
[RHEVM] [GUI] Assign/Detach Networks dialog shows incorrect flags on networks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: lpeer
yeylon@redhat.com
network
:
Depends On:
Blocks: 810675 830836 833648
  Show dependency treegraph
 
Reported: 2012-05-31 03:19 EDT by Martin Pavlik
Modified: 2016-04-18 02:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 04:37:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (26.19 KB, application/x-gzip)
2012-05-31 03:20 EDT, Martin Pavlik
no flags Details
engine.log (700 bytes, application/x-gzip)
2012-05-31 03:20 EDT, Martin Pavlik
no flags Details
Screenshot 1 - new network settings (155.57 KB, image/png)
2012-05-31 03:22 EDT, Martin Pavlik
no flags Details
Screenshot 2 - detached network (empty flags) (154.83 KB, image/png)
2012-05-31 03:23 EDT, Martin Pavlik
no flags Details
Screenshot 3 - network before reattach (155.12 KB, image/png)
2012-05-31 03:24 EDT, Martin Pavlik
no flags Details
Screenshot 4 - network after reattach (157.09 KB, image/png)
2012-05-31 03:25 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-31 03:19:09 EDT
Description of problem:
Assign/Detach Networks dialog shows incorrect flags on networks when network is attached/detached to cluster. 

Problems 

a) when network is detached from cluster no flags are shown (see screenshot 2)
b) when you try to reattach network which was marked as required before to cluster, required flag is missing, VM flag is not shown (see screenshot 3)


Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
1) Webadmin -> Clusters -> your cluster -> Logical  Networks -> Add Network
   a) fill in name -> click OK

2) Select new network -> Assign/Detach Networks
   a) uncheck attached on your network -> click OK

3) Click Assign/Detach Networks (all checkboxes empty) -> check Attached on your network (required flag missing, VM flag not shown) -> check Required -> click OK

4) Click Assign/Detach Networks (VM flag is filled again)

 
Actual results:
flags in Assign/Detach networks dialog are NOT shown/filled correctly

Expected results:
flags in Assign/Detach networks dialog are shown/filled correctly

Additional info:
Comment 1 Martin Pavlik 2012-05-31 03:20:25 EDT
Created attachment 587957 [details]
engine.log
Comment 2 Martin Pavlik 2012-05-31 03:20:56 EDT
Created attachment 587958 [details]
engine.log
Comment 3 Martin Pavlik 2012-05-31 03:22:50 EDT
Created attachment 587959 [details]
Screenshot 1 - new network settings
Comment 4 Martin Pavlik 2012-05-31 03:23:34 EDT
Created attachment 587960 [details]
Screenshot 2 - detached network (empty flags)
Comment 5 Martin Pavlik 2012-05-31 03:24:36 EDT
Created attachment 587961 [details]
Screenshot 3 - network before reattach
Comment 6 Martin Pavlik 2012-05-31 03:25:08 EDT
Created attachment 587962 [details]
Screenshot 4 - network after reattach
Comment 7 Einav Cohen 2012-06-12 00:21:20 EDT
After clicking "OK" in the Assign/Detach Network dialog, the non-attached networks are not being saved. This is why their flags after re-opening the dialog seem to not match. It is not a bug, generally, but the GUI dialog behavior is confusing.
Maybe for non-attached networks, the columns can be hidden or something similar - need to consult graphic designer about that.

Note You need to log in before you can comment on or make changes to this bug.