Bug 826863 - Disable vlan id when set network to disable
Disable vlan id when set network to disable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks: 1050818
  Show dependency treegraph
 
Reported: 2012-05-31 03:20 EDT by cshao
Modified: 2016-04-26 09:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, it was possible to enter a VLAN id into the network details page of the hypervisor installation screen, even when the network was disabled. Now, the VLAN id field is only enabled if the network is enabled.
Story Points: ---
Clone Of:
: 1050818 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:35:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2012-05-31 03:20:16 EDT
Description of problem:
Vlan id is available when set network to disable, it would be better if disable it when disable network.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6

How reproducible:
100%

Steps to Reproduce:
1. TUI Install REHV-H.
2. Enter network menu and configure network.
3. Choose "Disable" option and set vlan id=20, press "apply" button.
  
Actual results:
Network status show as "configured" in network menu.

Expected results:
Disable vlan id when set network to disable

Additional info:
Comment 2 Mike Burns 2012-05-31 16:02:26 EDT
Good negative test scenario, but not something that can be fixed in 6.3
Comment 4 RHEL Product and Program Management 2012-07-10 01:55:58 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:50:11 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Fabian Deutsch 2012-07-31 05:54:46 EDT
http://gerrit.ovirt.org/#/c/6783/

Tested as follows:
1. Installed Node
2. Copy o-c-setup into image
3. Enter NIC details page
4. VLAN ID field is disabled
5. Change to DHCP
6. VLAN ID field is enabled
7. Press Apply
8. Re-enter NIC details page
9. DHCP is selected and VLAN ID field is enabled
10. Enter VLAN ID 123 and apply
11. Re-enter NIC details page
12. VLAN ID is still set and field is enabled
Comment 12 errata-xmlrpc 2013-02-28 11:35:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.