Bug 826874 - libglade warning while launching subscription-manager-gui
libglade warning while launching subscription-manager-gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-31 03:48 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-05-31 03:48:33 EDT
Description of problem:
libglade warning while launching subscription-manager-gui

Version-Release number of selected component (if applicable):
[root@dhcp201-111 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gnome-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-migration-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-firstboot-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-1.0.2-1.git.2.2b23e6e.el5


How reproducible:


Steps to Reproduce:
1.subscription-manager-gui
2.
3.
  
Actual results:
[root@dhcp201-111 ~]# subscription-manager-gui

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVPaned'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'
/usr/share/rhsm/subscription_manager/gui/widgets.py:47: GtkWarning: gdk_gc_new: assertion `drawable != NULL' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:47: GtkWarning: gdk_gc_copy: assertion `GDK_IS_GC (dst_gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:47: GtkWarning: gdk_gc_set_values: assertion `GDK_IS_GC (gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:47: GtkWarning: gdk_gc_set_dashes: assertion `GDK_IS_GC (gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVPaned'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `invisible_char_set' for class `GtkEntry'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVPaned'

(subscription-manager-gui:31384): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'
/usr/sbin/subscription-manager-gui:128: GtkWarning: gdk_draw_line: assertion `gc != NULL' failed
  sys.exit(gtk.main() or 0)


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-06-01 11:40:11 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Alex Wood 2012-07-10 13:16:05 EDT
commit dd60fe22bdbaabd592187061b1e0d6fd7fced7b2
Refs: subscription-manager-1.0.7-1-1-gdd60fe2
Author:     Adrian Likins <alikins@redhat.com>
AuthorDate: Thu Jun 28 13:59:28 2012 -0400
Commit:     Adrian Likins <alikins@redhat.com>
CommitDate: Thu Jun 28 13:59:28 2012 -0400

    826874: Remove unneeded property 'orientation' from glade
Comment 4 Sharath Dwaral 2012-07-30 17:55:40 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
python-rhsm-1.0.4-1.git.6.19a55da.el5
subscription-manager-firstboot-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-1.0.11-1.git.3.b3c4a8b.el5

Verification:

# subscription-manager-gui

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `invisible_char_set' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `invisible_char_set' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `invisible_char_set' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `has_tooltip' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `invisible_char_set' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:31862): libglade-WARNING **: unknown property `track_visited_links' for class `GtkLabel'
/usr/share/rhsm/subscription_manager/gui/widgets.py:52: GtkWarning: gdk_gc_new: assertion `drawable != NULL' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:52: GtkWarning: gdk_gc_copy: assertion `GDK_IS_GC (dst_gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:52: GtkWarning: gdk_gc_set_values: assertion `GDK_IS_GC (gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/share/rhsm/subscription_manager/gui/widgets.py:52: GtkWarning: gdk_gc_set_dashes: assertion `GDK_IS_GC (gc)' failed
  self.glade = gtk.glade.XML(os.path.join(GLADE_DIR, glade_file))
/usr/sbin/subscription-manager-gui:127: GtkWarning: gdk_draw_line: assertion `gc != NULL' failed
  sys.exit(gtk.main() or 0)

Actual Result:
Shown Above

Expected Result:
libglade-WARNING should not be displayed

Moving bug back to NEW - FailedQA
Comment 5 Bryan Kearney 2012-08-13 09:25:53 EDT
Can not re-produce with 1.0.13 test. Please re-verify with 1.0.14.
Comment 6 Shwetha Kallesh 2012-08-14 07:16:27 EDT
Verified!! As there are no warnings now..

[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.13-1.git.20.5346dac.el5
subscription-manager-1.0.13-1.git.20.5346dac.el5
subscription-manager-gui-1.0.13-1.git.20.5346dac.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.13-1.git.20.5346dac.el5

[root@dhcp201-115 ~]# subscription-manager-gui
Comment 8 errata-xmlrpc 2013-01-07 22:53:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.