Bug 826922 - rhev fails to boot from local disk under UEFI mode on DELL optiplex 990
rhev fails to boot from local disk under UEFI mode on DELL optiplex 990
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: ZStream
: 871548 (view as bug list)
Depends On:
Blocks: 846430 871548
  Show dependency treegraph
 
Reported: 2012-05-31 05:10 EDT by yuanquan chen
Modified: 2016-04-26 12:18 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
When installing Red Hat Enterprise Virtualization Hypervisor via a usb stick, the system fails to boot from a local disk in UEFI mode. The grub device ordering changed when Red Hat Enterprise Virtualization Hypervisor was installed, causing the system not to recognize the local disk correctly. This fix changes the device ordering by removing old EFI entries and setting hd0 as the boot device in the EFI grub configuration file.
Story Points: ---
Clone Of:
: 923049 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:35:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuanquan chen 2012-05-31 05:10:56 EDT
Description of problem:
Boot from usb boot media under UEFI mode and install the rhev-h to the
local disk on DELL optiplex 990 successfully. But it fails to boot from
the installed local disk under UEFI mode.

The main cause is that it fails to load the kernel and initrd from the
installed local disk. The BOOTX64.conf under the EFI partition specifies
the root as "root (hd0,2)". If I change it as "root (hd1,2)", then
it successes to load the kernel and initrd and boots up.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6


How reproducible:
100%

Steps to Reproduce:
1. prepare an efi supported usb boot media with "rhevh-iso-to-disk
--format --efi rhevh-6.3-20120523.1.el6.iso /dev/sdb"
2. boot the DELL optiplex 990 from the usb disk under UEFI mode and
install rhev-h to local disk
3. boot from local disk under UEFI mode
  
Actual results:
It prompts failing to load the splash.xpm.gz and vmlinux and initrd


Expected results:
It successes to boot from local disk under UEFI mode and no error
occurs. 


Additional info:
Comment 2 yuanquan chen 2012-05-31 06:22:53 EDT
Though it fails to boot from installed local disk in UEFI mode directly after install, while it can boot up under UEFI mode when I add a CD to the DELL optiplex 990. From the phenomenon above, we can get the conclusion that grub under UEFI recognizes the local disk as hd1, while adding a CD to the machine, it recognizes the local disk as hd0.
Comment 3 Mike Burns 2012-05-31 16:16:23 EDT
Issue is related to the fact that you're installing from a USB stick.  Too late to fix for 6.3, deferring to 6.4
Comment 5 Guohua Ouyang 2012-06-05 04:00:33 EDT
(In reply to comment #4)

> btw, cannot test install from cdrom or virtual media on that machine so far.

cannot test install from cdrom due to the machine IBM 3550 M3 have no cdrom, tried a usb cdrom, cannot boot, nothing happen, just return to bios.
Comment 7 Mike Burns 2012-07-13 14:17:06 EDT
jboggs -- you know the steps that need to be taken to fix this right?

The base issue here, iirc, is that when you install from usb stick, the grub device ordering isn't right, so you need to either leave the usb stick in the machine or remove it (I don't recall which it is that needs to be done)
Comment 8 Joey Boggs 2012-07-13 14:56:23 EDT
ordering can be fixed by setting hd0 = bootdevice in the efi grub config. I had a conversation with grub/uefi folks about it awhile back just need to add the line after getting the right uuid
Comment 9 Mike Burns 2012-07-13 15:36:37 EDT
OK, can you get a patch worked out relatively soon?  I'd like to get this into Update 3.

Thanks
Comment 13 haiyang,dong 2012-11-01 23:34:15 EDT
Test version:
rhev-hypervisor6-6.4-20121031.0.el6
ovirt-node-2.5.0-8.el6

Steps:
1. prepare an efi supported usb boot media with "rhevh-iso-to-disk
--format --efi rhevh-6.3-20120523.1.el6.iso /dev/sdb"
2. boot the DELL optiplex 990 from the usb disk under UEFI mode and
install rhev-h to local disk
3. boot from local disk under UEFI mode

Test result:
It successes to boot from local disk under UEFI mode and no error
occurs. 

so this bug has been fixed. change the status to "VERIFIED"
Comment 16 Mike Burns 2012-12-13 10:42:29 EST
*** Bug 871548 has been marked as a duplicate of this bug. ***
Comment 17 haiyang,dong 2012-12-27 01:15:00 EST
so follow steps of comment 13 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 19 errata-xmlrpc 2013-02-28 11:35:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.