Bug 827000 - [virtio-win][scsi]Fail to boot the windows guest with virtio-blk-pci system image and virtio-scsi data disk
[virtio-win][scsi]Fail to boot the windows guest with virtio-blk-pci system i...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 07:59 EDT by Sibiao Luo
Modified: 2013-02-21 05:38 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2012-05-31 07:59:40 EDT
Description of problem:
boot the windows guest with virtio-blk-pci system image and virtio-scsi data disk, the QEMU will quit and the windows guest fail to boot up. Since we have no SCSI driver for windows, the guest shouldn't detect the data disk, it's probably a bug in the Windows driver, the QEMU shouldn't quit.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-274.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
guest info:
guest name: windows_2008_r2_sp1_x64
WHQL driver: virtio-win-1.5.1-1

How reproducible:
100%

Steps to Reproduce:
1.boot the windows guest with virtio-blk-pci system image and virtio-scsi data disk.
eg: # /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu SandyBridge -enable-kvm -smp 2 -m 2G -usb -device usb-tablet,id=input0 -name test_sluo -uuid `uuidgen` -drive file=/home/windows_2008_r2_sp1_x64.qcow2,if=none,id=hd,format=qcow2,aio=native,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=hd,id=blk_image,scsi=off,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0 -vnc :1 -balloon none -device sga -chardev socket,id=serial0,path=/var/sluo,server,nowait -device isa-serial,chardev=serial0 -monitor unix:/tmp/monitor2,server,nowait -monitor stdio -qmp tcp:0:4444,server,nowait -drive file=/home/my_data_disk.qcow2,format=qcow2,if=none,cache=none,id=sluo_drive,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0 -device scsi-hd,drive=sluo_drive,bus=scsi0.0,id=scsi_image -drive file=/usr/share/virtio-win/virtio-win-1.5.1.iso,if=none,id=drive-ide0-0-3,werror=stop,rerror=stop,cache=none,format=raw,media=cdrom,readonly=on -device ide-drive,drive=drive-ide0-0-3,id=ide0-0-3,bus=ide.1,unit=1 -drive file=/usr/share/virtio-win/virtio-win-1.5.1.vfd,if=none,id=f1,format=raw,cache=none -global isa-fdc.driveA=f1
2.
3.
  
Actual results:
after the step 1, the QEMU will quit and the windows guest fail to boot up.

Expected results:
the guest should boot up successfull without problem.

Additional info:
Comment 1 Mike Cao 2012-05-31 09:02:21 EDT
(In reply to comment #0)
> Description of problem:
> boot the windows guest with virtio-blk-pci system image and virtio-scsi data
> disk, the QEMU will quit and the windows guest fail to boot up. Since we
> have no SCSI driver for windows, the guest shouldn't detect the data disk,
> it's probably a bug in the Windows driver, the QEMU shouldn't quit.
> 
> Version-Release number of selected component (if applicable):
> host info:
> # uname -r && rpm -q qemu-kvm-rhev
> 2.6.32-274.el6.x86_64
> qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64
> guest info:
> guest name: windows_2008_r2_sp1_x64
> WHQL driver: virtio-win-1.5.1-1
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1.boot the windows guest with virtio-blk-pci system image and virtio-scsi
> data disk.
> eg: # /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu SandyBridge -enable-kvm -smp 2
> -m 2G -usb -device usb-tablet,id=input0 -name test_sluo -uuid `uuidgen`
> -drive
> file=/home/windows_2008_r2_sp1_x64.qcow2,if=none,id=hd,format=qcow2,
> aio=native,cache=none,werror=stop,rerror=stop -device
> virtio-blk-pci,drive=hd,id=blk_image,scsi=off,bootindex=1 -netdev
> tap,script=/etc/qemu-ifup,id=netdev0 -device
> virtio-net-pci,netdev=netdev0,id=device-net0 -vnc :1 -balloon none -device
> sga -chardev socket,id=serial0,path=/var/sluo,server,nowait -device
> isa-serial,chardev=serial0 -monitor unix:/tmp/monitor2,server,nowait
> -monitor stdio -qmp tcp:0:4444,server,nowait -drive
> file=/home/my_data_disk.qcow2,format=qcow2,if=none,cache=none,id=sluo_drive,
> werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0 -device
> scsi-hd,drive=sluo_drive,bus=scsi0.0,id=scsi_image -drive
> file=/usr/share/virtio-win/virtio-win-1.5.1.iso,if=none,id=drive-ide0-0-3,
> werror=stop,rerror=stop,cache=none,format=raw,media=cdrom,readonly=on
> -device ide-drive,drive=drive-ide0-0-3,id=ide0-0-3,bus=ide.1,unit=1 -drive
> file=/usr/share/virtio-win/virtio-win-1.5.1.vfd,if=none,id=f1,format=raw,
> cache=none -global isa-fdc.driveA=f1
> 2.
> 3.
>   
> Actual results:
> after the step 1, the QEMU will quit and the windows guest fail to boot up.
> 
> Expected results:
> the guest should boot up successfull without problem.
> 
> Additional info:

In which stage during boot did qemu-kvm instance quit ?
Do you have Any quit error message ?
Comment 2 Sibiao Luo 2012-05-31 09:35:14 EDT
(In reply to comment #1)
> (In reply to comment #0)
 
> > Actual results:
> > after the step 1, the QEMU will quit and the windows guest fail to boot up.
> > 
> 
> In which stage during boot did qemu-kvm instance quit ?
> Do you have Any quit error message ?

sorry for my mistake, I forget paste the prompts of the QEMU when it quit at the guest screen displaying "Plesse wait for the Local Session Manager..." during boot. 
(qemu) qemu-kvm: wrong size for virtio-scsi headers
Comment 3 Sibiao Luo 2012-06-28 01:07:50 EDT
Hi all,

   I have tried the virtio-win-prewhql-0.1-29 with the same steps, and boot the windows guest with virtio-blk-pci system image and virtio-scsi data disk successfully. After that, install the SCSI driver from Install\amd64\vioscsi, the data disk can be initalized and formatted successfully, and can be read and write correctly. So, this issue has gone.

host info:
# uname -r && rpm -q qemu-kvm
2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
guest info:
guest name: windows_2008_r2_sp1_x64
WHQL driver: virtio-win-prewhql-0.1-29

Best wish
sluo
Comment 4 Sibiao Luo 2012-06-28 01:42:18 EDT
(In reply to comment #3)
> 

sorry for my carelessness, the SCSI driver is from Install/Wlh/amd64/vioscsi.inf.

Base on the Comment #3, set this issue to VERIFIED status & thx.
Comment 5 errata-xmlrpc 2013-02-21 05:38:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.