Bug 827040 - missing header: bits/sysctl.h -- included by sys/sysctl.h
missing header: bits/sysctl.h -- included by sys/sysctl.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:50 EDT by Jim Meyering
Modified: 2016-11-24 10:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 23:45:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Meyering 2012-05-31 09:50:23 EDT
Description of problem:
/usr/include/sys/sysctl.h includes missing header, bits/sysctl.h.

Version-Release number of selected component (if applicable):

How reproducible: every time

Steps to Reproduce:
1.  Run this:

  :|gcc -include sys/sysctl.h -E -x c /dev/null > /dev/null

Actual results:

    In file included from <command-line>:0:0:
    /usr/include/sys/sysctl.h:63:25: fatal error: bits/sysctl.h: \
      No such file or directory
    compilation terminated.

Expected results:

    no error

Additional info:

  It looks like it's due to the addition of this single line:

      #include <bits/sysctl.h>

  I was able to work around it by commenting out that line.
Comment 2 Jeff Law 2012-05-31 23:45:46 EDT
Resync'd with upstream to pick up the fix.  Build spinning.

Note You need to log in before you can comment on or make changes to this bug.