Bug 827070 - ovirt-engine-backend: cannot add or attach a second disk to vm after attaching a floating disk
ovirt-engine-backend: cannot add or attach a second disk to vm after attachin...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: 3.1.0
Assigned To: mkublin
Dafna Ron
storage
:
: 819908 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 10:42 EDT by Dafna Ron
Modified: 2016-02-10 12:16 EST (History)
11 users (show)

See Also:
Fixed In Version: SI6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (36.63 KB, application/x-xz)
2012-05-31 10:42 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-31 10:42:17 EDT
Created attachment 588109 [details]
log

Description of problem:

we are blocked from adding a second disk to vm after attaching a floating disk with error:

Cannot add Virtual Machine Disk. The chosen disk drive letter is already in use, please select a free one.

this is both for automated disk alias selection and when manually chaning the disk alais. 

I tested the below:

1. vm with no disk -> attach a disk -> try to create a new disk = fail
2. vm with existing disk -> attach a disk -> try to create a new disk = fail
3. vm with existing disk -> attach a disk -> try to attach a second disk = fail


backend can_do is: 

2012-05-28 17:21:47,593 WARN  [org.ovirt.engine.core.bll.AddDiskCommand] (ajp--0.0.0.0-8009-2) [3daca1df] CanDoAction of action AddDisk failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISK_LETTER_ALREADY_IN_USE

I tested both for disks 
Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create a vm with no disks 
2. attach a disk that was created as floating disk
3. try to add a second disk to the vm
  
Actual results:

we are blocked with can_do_action from backend about disk name 

Expected results:

we should be able to create/attach another disk 

Additional info:full log
Comment 1 mkublin 2012-06-03 09:56:04 EDT
The following commit will solve a bug:
http://gerrit.ovirt.org/#change,4984

From now, there are no internal drive mapping at the system
Comment 2 mkublin 2012-06-05 08:22:22 EDT
*** Bug 819908 has been marked as a duplicate of this bug. ***
Comment 3 Dafna Ron 2012-06-14 09:00:51 EDT
verified on si6

Note You need to log in before you can comment on or make changes to this bug.