Bug 827072 - Deprecated tag used in sample multipath.conf file
Deprecated tag used in sample multipath.conf file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Petr Beňas
:
Depends On:
Blocks: 782183 846704 856826
  Show dependency treegraph
 
Reported: 2012-05-31 10:43 EDT by Sven Bold
Modified: 2015-01-04 18:02 EST (History)
15 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-56.el6
Doc Type: Bug Fix
Doc Text:
Doc change. No documentation necessary
Story Points: ---
Clone Of:
: 856826 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:50:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Bold 2012-05-31 10:43:45 EDT
Description of problem:
The sample file "/usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf"
contains a deprecated tag in the defaults section...
        #defaults {                                                     
        #       udev_dir                /dev                            
        #       polling_interval        10                              
====>   #       selector                "round-robin 0"  <=======       

In RHEL6 I beleve it should be "path_selector" instead. The following error results when using this configuration.

"[root@rhev-h4 ~]# multipath
May 31 14:35:17 | multipath.conf line 29, invalid keyword: selector"

Changing this to path_selector as per the man page solves this.
I had a customer run into this problem when using the sample file
as a basis for a new configuration.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-46.el6_2.2.x86_64



How reproducible:
Always


Steps to Reproduce:
1.copy /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf to /etc
2.Uncomment defaults section 
3.run "multipath command"
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2012-06-04 01:47:23 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Ben Marzinski 2012-10-10 22:17:12 EDT
Changed selector to path_selector.
Comment 8 Petr Beňas 2012-10-15 07:16:47 EDT
Reproduced in device-mapper-multipath-0.4.9-57.el6.x86_64 and verified in device-mapper-multipath-0.4.9-59.el6.x86_64.
Comment 11 errata-xmlrpc 2013-02-21 05:50:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0458.html

Note You need to log in before you can comment on or make changes to this bug.