Bug 827160 - Installing dracut-fips prevents dracut from working on i686
Installing dracut-fips prevents dracut from working on i686
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 15:03 EDT by Philippe Troin
Modified: 2012-12-20 11:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:20:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2012-05-31 15:03:54 EDT
Description of problem:
Installing dracut-fips makes dracut fail:

/sbin/dracut -v -f /boot/initramfs-3.3.7-1.fc17.i686.PAE.img 3.3.7-1.fc17.i686.PAE
I: *** Including module: fips ***
F: Failed to install /usr/lib64/hmaccalc/sha512hmac.hmac

There is no hmacalc under lib64, but there's one under /lib.

Version-Release number of selected component (if applicable):
dracut-fips-40.git20120522.fc17

How reproducible:
Always

Steps to Reproduce:
1.Install dracut-fips on an i686
2.Regenerate an initrd
  
Actual results:
F: Failed to install /usr/lib64/hmaccalc/sha512hmac.hmac

Expected results:
Should succeed.
Comment 1 Harald Hoyer 2012-06-04 04:51:28 EDT
why do you have /usr/lib64?
Comment 2 Philippe Troin 2012-06-04 12:30:20 EDT
No, it's an i686 system.
Yet dracut-fips references a /usr/lib64 file.

Phil.
Comment 3 Harald Hoyer 2012-07-03 04:33:32 EDT
(In reply to comment #1)
> why do you have the /usr/lib64 or /lib64 on your system?
Comment 4 Philippe Troin 2012-07-03 04:40:04 EDT
Good question :-)

% find /usr/lib64
/usr/lib64
/usr/lib64/gems
/usr/lib64/gems/exts
/usr/lib64/xchat
/usr/lib64/xchat/plugins
/usr/lib64/xchat/plugins/xas.pl

% rpm -qf $(find /usr/lib64)
file /usr/lib64 is not owned by any package
rubygems-1.8.24-1.fc17.noarch
rubygems-1.8.24-1.fc17.noarch
file /usr/lib64/xchat is not owned by any package
file /usr/lib64/xchat/plugins is not owned by any package
xchat-amule-2.3.1-2.fc17.noarch
Comment 5 Harald Hoyer 2012-07-05 06:11:19 EDT
(In reply to comment #4)
> Good question :-)
> 
> % find /usr/lib64
> /usr/lib64
> /usr/lib64/gems
> /usr/lib64/gems/exts
> /usr/lib64/xchat
> /usr/lib64/xchat/plugins
> /usr/lib64/xchat/plugins/xas.pl
> 
> % rpm -qf $(find /usr/lib64)
> file /usr/lib64 is not owned by any package
> rubygems-1.8.24-1.fc17.noarch
> rubygems-1.8.24-1.fc17.noarch
> file /usr/lib64/xchat is not owned by any package
> file /usr/lib64/xchat/plugins is not owned by any package
> xchat-amule-2.3.1-2.fc17.noarch

oh my... noarch in lib64? are they nuts? Can you please file bugs? I'll fix the dracut package.
Comment 6 Fedora Update System 2012-09-27 06:22:13 EDT
dracut-018-60.git20120927.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-018-60.git20120927.fc16
Comment 7 Fedora Update System 2012-09-27 06:23:18 EDT
dracut-018-105.git20120927.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-105.git20120927.fc17
Comment 8 Fedora Update System 2012-09-27 06:30:44 EDT
dracut-018-105.git20120927.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-105.git20120927.fc17
Comment 9 Fedora Update System 2012-09-28 04:20:19 EDT
Package dracut-018-105.git20120927.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-018-105.git20120927.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14953/dracut-018-105.git20120927.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-12-20 11:20:57 EST
dracut-018-105.git20120927.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.