Bug 827214 - [ta_IN] failed pofilter xmltags tests for subscription-manager translations
[ta_IN] failed pofilter xmltags tests for subscription-manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation, Triaged
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-31 18:03 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-05-31 18:03:30 EDT
Description of problem:
The gnome xmltags were not properly translated for 'ta_IN' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:
[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t xmltags /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-03-20 02:59-0400\n"
"Last-Translator: ifelix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) xmltags: Different XML tags
msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "%s வரை தயாரிப்பு உரிம சான்றிதழ்கள்  <i>செல்லுபடியாகும் <i>"

# (pofilter) xmltags: Different XML tags
msgid "You have <b>%s</b> products in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>%s</b> தயாரிப்புகள் தேவைப்படுகிறது. "

# (pofilter) xmltags: Different XML tags
msgid "You have <b>1</b> product in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>1</b> தயாரிப்பு தேவைப்படுகிறது."


Actual results:
Shown above

Expected results:

msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "%s வரை தயாரிப்பு உரிம சான்றிதழ்கள்  <i>செல்லுபடியாகும் </i>"

msgid "You have <b>%s</b> products in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் </i> உரிம சான்றிதழ்களுக்கு <b>%s</b> தயாரிப்புகள் தேவைப்படுகிறது. "

msgid "You have <b>1</b> product in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் </i> உரிம சான்றிதழ்களுக்கு <b>1</b> தயாரிப்பு தேவைப்படுகிறது."

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#xmltags
Comment 2 RHEL Product and Program Management 2012-06-04 01:47:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Alex Wood 2012-06-18 11:23:32 EDT
commit 8622d70ef6e4370aa6f043a83bbef9a9292a2984
Refs: subscription-manager-1.0.2-1-102-g8622d70
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Wed Jun 6 15:37:53 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Wed Jun 6 15:38:40 2012 -0400

    827214: Clean up the XML tags in ta po file.
Comment 4 RHEL Product and Program Management 2012-06-18 11:28:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 Sharath Dwaral 2012-07-12 14:56:09 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Steps:


# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po

# pofilter --gnome -t xmltags /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po

processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2011-04-01 03:35-0400\n"
"Last-Translator: I Felix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) xmltags: Different XML tags
msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "%s வரை தயாரிப்பு உரிம சான்றிதழ்கள்  <i>செல்லுபடியாகும் <i>"

# (pofilter) xmltags: Different XML tags
msgid "You have <b>%s</b> products in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>%s</b> தயாரிப்புகள் தேவைப்படுகிறது. "

# (pofilter) xmltags: Different XML tags
msgid "You have <b>1</b> product in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>1</b> தயாரிப்பு தேவைப்படுகிறது."
[###########################################] 100%


>FailedQA
Comment 7 Sharath Dwaral 2012-07-12 15:44:47 EDT
Expected Results:

msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "%s வரை தயாரிப்பு உரிம சான்றிதழ்கள்  <i>செல்லுபடியாகும் </i>"


msgid "You have <b>%s</b> products in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் </i> உரிம சான்றிதழ்களுக்கு <b>%s</b> தயாரிப்புகள் தேவைப்படுகிறது. "


msgid "You have <b>1</b> product in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i/> உரிம சான்றிதழ்களுக்கு <b>1</b> தயாரிப்பு தேவைப்படுகிறது."
Comment 8 Shantha kumar 2012-07-24 02:57:23 EDT
//The gnome xmltags were not properly translated for 'ta_IN' language.//

I have fixed this bug.
Comment 9 Ankit Patel 2012-07-24 04:23:24 EDT
A fix can be found from: https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.0.X

Thanks Shantha.

/Ankit
Comment 10 Sharath Dwaral 2012-07-24 17:56:06 EDT
Moving bug to MODIFIED as it seems to fixed in the latest ZANATA commit
Comment 11 Sharath Dwaral 2012-07-24 18:10:18 EDT
Version:
# rpm -qa| egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.10-1.git.25.8954ca8.el5
subscription-manager-1.0.10-1.git.25.8954ca8.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.34.b74ea4f.el5
subscription-manager-firstboot-1.0.10-1.git.25.8954ca8.el5
subscription-manager-gui-1.0.10-1.git.25.8954ca8.el5

Verification:

# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
# pofilter --gnome -t xmltags /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-18 10:48-0400\n"
"PO-Revision-Date: 2011-04-01 03:35-0400\n"
"Last-Translator: I Felix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) xmltags: Different XML tags
msgid "Product entitlement certificates <i>valid</i> until %s"
msgstr "%s வரை தயாரிப்பு உரிம சான்றிதழ்கள்  <i>செல்லுபடியாகும் <i>"

# (pofilter) xmltags: Different XML tags
msgid "You have <b>%s</b> products in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>%s</b> தயாரிப்புகள் தேவைப்படுகிறது. "

# (pofilter) xmltags: Different XML tags
msgid "You have <b>1</b> product in need of <i>additional</i> entitlement certificates."
msgstr " <i>கூடுதல் <i> உரிம சான்றிதழ்களுக்கு <b>1</b> தயாரிப்பு தேவைப்படுகிறது."
[###########################################] 100%

The above results are False Negatives
Moving bug to VERIFIED
Comment 13 errata-xmlrpc 2013-01-07 22:53:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.