Bug 827312 - ValueError: need more than 1 value to unpack
ValueError: need more than 1 value to unpack
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:684040b9b9050db7822f81d7171...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 02:10 EDT by Hongqing Yang
Modified: 2013-01-10 01:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 15:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-SH4IGx (722.00 KB, text/plain)
2012-06-01 02:11 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-06-01 02:10:53 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-SH4IGx
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Fri 01 Jun 2012 02:10:24 PM CST
version:        17

anaconda-tb-SH4IGx: Text file, 739328 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 438, in configBaseURL
:    (device, fstype, path) = m[3:].split(":")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 363, in setup
:    self.configBaseURL()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1249, in doBackendSetup
:    self.ayum.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 192, in doBackendSetup
:    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:ValueError: need more than 1 value to unpack

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=/vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:LVM_SUPPRESS_FD_WARNINGS=1
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.iYMrVm
:repo=hd:sdb1
:PWD=/
:MALLOC_PERTURB_=204
:TZ=Asia/Shanghai
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Hongqing Yang 2012-06-01 02:11:03 EDT
Created attachment 588317 [details]
File: anaconda-tb-SH4IGx
Comment 2 Jesse Keating 2012-07-16 17:44:20 EDT
Your repo= option is invalid.  You need to provide a path as well as the device.

http://fedoraproject.org/wiki/Anaconda/Options#repo

That said, we might be able to do something better than a traceback here.
Comment 3 Jesse Keating 2012-10-16 15:38:00 EDT
This code doesn't even exist in F18 now.  Closing.

Note You need to log in before you can comment on or make changes to this bug.