Bug 827333 - Console doesn't report failure reason when auto install RHEV-H to non-existent disk.
Console doesn't report failure reason when auto install RHEV-H to non-existen...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 03:14 EDT by cshao
Modified: 2016-04-26 12:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Automatically installing the hypervisor to a non-existent disk yielded an unhelpful error message because of an ovirt-early mask implemented for testing the disk's validity. Now, automatic installation attempted on a non-existent disk reports "Device specified in storage_init does not exist".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:35:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2012-06-01 03:14:18 EDT
Description of problem:
Console doesn't report failure reason when auto install RHEV-H to non-existent disk.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Auto install RHEV-H to non-existent disk.
storage_init=/dev/sde firstboot (sde is non-existent disk)
2.
3.
  
Actual results:
1. Ovirt.log only report below info:
"Automatic installation failed. Please review console messages".
Actually console doesn't report failure reason when auto install RHEV-H to non-existent disk.

ovirt.log
==========================
Jun 01 01:55:09 Starting ovirt-early
Red Hat Enterprise Virtualization Hypervisor release 6.3 (20120531.0)
Jun 01 01:55:09 Automatic installation failed. Please review console messages.
Jun 01 01:55:09 Press Enter to drop to emergency shell.

[root@localhost /]# cat /proc/cmdline
initrd=/images/rhev-hypervisor6-6.3-20120531.0.el6/initrd0.img ksdevice=bootif rootflags=loop rootflags=ro liveimg crashkernel=512M-2G:64M,2G-:128M rootfstype=auto check lang=  rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb install ro root=live:/rhev-hypervisor.iso rd_NO_DM  BOOTIF=01-b8-ac-6f-3e-63-66 storage_init=/dev/sde console=ttyS0,115200n8 firstboot BOOT_IMAGE=/images/rhev-hypervisor6-6.3-20120531.0.el6/vmlinuz0

Expected results:
Console can report the detail failure reason when auto install RHEV-H to non-existent disk.(e.g. The disk /dev/sde is non-existent)

Additional info:
Comment 4 RHEL Product and Program Management 2012-07-10 02:33:30 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:50:31 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 10 errata-xmlrpc 2013-02-28 11:35:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.