Bug 827359 - failed to alter domain with scalable jbossas app exsit
failed to alter domain with scalable jbossas app exsit
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Regression, Triaged
Depends On: 828038
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 04:39 EDT by Meng Bo
Modified: 2015-05-14 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: stage
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-06-01 04:39:53 EDT
Description of problem:
create scalable jbossas app, and try to alter domain will get failure.

Version-Release number of selected component (if applicable):
devenv_1812

How reproducible:
always

Steps to Reproduce:
1.create scalable jbossas app
2.try to alter domain namespace
3.
  
Actual results:
Error updating apps: ["jbs1s"].  Updates will not be completed until all apps can be updated successfully.  If the problem persists please contact support.


Expected results:
domain should be altered without any error.

Additional info:
there is no this problem for other five type apps.

mcollective log:
D, [2012-06-01T04:32:36.355388 #1040] DEBUG -- : libra.rb:522:in `execute_parallel_action' execute_parallel_action call / request = #<MCollective::RPC::Request:0x7f264b449800
 @action="execute_parallel",
 @agent="libra",
 @caller="cert=mcollective-public",
 @data=
  {"ip-10-111-6-241"=>
    [{:job=>
       {:cartridge=>"stickshift-node",
        :args=>
         {"--hook-name"=>"set-proxy",
          "--gear-uuid"=>"3e8fcc116b394388b779aab67477d491",
          "--cart-name"=>"haproxy-1.4",
          "--input-args"=>
           "jbs1s bmeng1dev 3e8fcc116b394388b779aab67477d491 \\'881a91b24f1f43d19906972bd3bbfbc6\\'\\=\\'881a91b24f-bmeng1dev1.dev.rhcloud.com\\|10.111.6.241:35536'\n'\\'"},
        :action=>"connector-execute"},
      :result_exit_code=>"",
      :result_stdout=>"",
      :result_stderr=>"",
      :tag=>"",
      :gear=>"3e8fcc116b394388b779aab67477d491"}],
   :process_results=>true},
 @sender="ip-10-111-6-241",
 @time=1338539556,
 @uniqid="da8d33587f92f22ad31daa4b5757b19c">
Comment 1 Meng Bo 2012-06-01 07:17:23 EDT
checked on devenv-stage_198, it will success sometimes, and also will fail sometime.
Comment 2 Bill DeCoste 2012-06-01 17:04:27 EDT
Unable to reproduce. 10 alters, all worked.
Comment 4 Meng Bo 2012-06-05 07:18:05 EDT
verified on devenv_1815, issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.