Bug 827383 - The default boot version is not latest one and the backup one boot failed.
The default boot version is not latest one and the backup one boot failed.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 834348
  Show dependency treegraph
 
Reported: 2012-06-01 06:12 EDT by shaochen
Modified: 2016-04-26 10:10 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, a successful kernel upgrade of a Red Hat Enterprise Virtualization Hypervisor node did not result in the default boot option in grub being changed to the latest kernel version. Additionally, the backup kernel option in the grub menu would not boot. Now, the grub menu is updated to boot the latest kernel by default, and the backup kernel option works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:35:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backup boot failed (8.82 KB, image/jpeg)
2012-06-15 04:00 EDT, shaochen
no flags Details
Default boot is backup (62.90 KB, image/jpeg)
2012-06-15 04:02 EDT, shaochen
no flags Details

  None (edit)
Description shaochen 2012-06-01 06:12:05 EDT
Description of problem:
The default boot version is not latest one and the backup one boot failed.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H 6.2 GA (6.2-20111117) version and register to RHEV-M.
2. Upgrade RHEV-H to the latest version(rhev-hypervisor6-6.3-20120531.0.el6) via rhevm.
3. After upgrade successful, manual reboot RHEV-H.
  
Actual results:
1. The default boot version is not latest one and the backup one boot failed.
2. The same issue occurs when upgrade via kernel command.

# cat /dev/.initramfs/live/grub/grub.conf 
default saved
timeout 5
hiddenmenu
title Red Hat Enterprise Virtualization Hypervisor (6.3-20120531.0)
    root (hd0,1)
    kernel /vmlinuz0 root=live:LABEL=Root ro rootfstype=ext2 rootflags=ro ksdevice=bootif processor.max_cstate=1 crashkernel=512M-2G:64M,2G-:128M rd_NO_LVM lang= nomodeset rd_NO_LUKS rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img
title BACKUP RHEV Hypervisor 6.2-20120117.0.el6_2
    root (hd0,0)
    kernel /vmlinuz0 root=live:LABEL=RootBackup ro rootfstype=ext2 rootflags=ro ksdevice=bootif processor.max_cstate=1 crashkernel=512M-2G:64M,2G-:128M rd_NO_LVM lang= nomodeset rd_NO_LUKS rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img
    savedefault


Expected results:
1. The default boot version is the latest one.
2. Back version boot successful.

Additional info:
No such issue when upgrade from RHEV-H 6.2 GA (6.2-20111117) to 6.2-20120510, so it is a regression bug.
Comment 3 Guohua Ouyang 2012-06-13 05:19:08 EDT
Seems it cannot be always reproduced, I tested upgrade from 6.2-20111117.0 to 6.3-20120606.3 via rhevm, not meet this issue.
Comment 4 shaochen 2012-06-15 04:00:24 EDT
Created attachment 592065 [details]
backup boot failed
Comment 5 shaochen 2012-06-15 04:02:14 EDT
Created attachment 592066 [details]
Default boot is backup
Comment 6 Mike Burns 2012-06-20 10:31:22 EDT
OK, reproduced this and found at least 1 root cause:

We don't handle savedefault correctly in the case of upgrades done with "upgrade" or "local_boot" options or when upgrade is triggered through RHEV-M.

Selecting the correct entry in grub does boot correctly, but savedefault is still not handled correctly.

Also, backup entry does, in fact, not boot.
Comment 8 Guohua Ouyang 2012-06-20 23:26:59 EDT
test with rhev-hypervisor6-6.3-20120615.1.auto463.el6.iso:
1. upgradem from 6.2-20111117.1 to 6.3-20120615.1.auto463.el6 via rhevm: 
   default boot entry is 6.3
   both 6.3 and BACKUP entry can boot successfully.

2. upgradem from 6.2-20111117.1 to 6.3-20120615.1.auto463.el6 via tui: 
   default boot entry is 6.3
   both 6.3 and BACKUP entry can boot successfully.

3. upgradem from 6.2-20111117.1 to 6.3-20120615.1.auto463.el6 via cmd line: 
   default boot entry is 6.3
   both 6.3 and BACKUP entry can boot successfully.
Comment 13 haiyang,dong 2012-08-29 05:34:45 EDT
Test with rhev-hypervisor6-6.3-20120815.0.iso:
Steps to Reproduce:
1.Clean install rhev-hypervisor6-6.2-20111117.0 version
2.Upgrade RHEV-H to the version rhev-hypervisor6-6.3-20120813.0 via TUI.
3.Then upgrade it to the latest version rhev-hypervisor6-6.3-20120815.0 via TUI
4.After upgrade successful, manual reboot RHEV-H.
5.Select the backup version rhev-hypervisor6-6.3-20120813.0 to boot

Actual results:
1.after step 2, it can boot from the backup version(rhev-hypervisor6-6.2-20111117.0)
2.After step 5, boot the backup version rhev-hypervisor6-6.3-20120813.0 failed at "starting ovirt-past" and it will reboot again.Repeat step 5, have the same issue.

Expected results:
After step 5,the backup version rhev-hypervisor6-6.3-20120813.0 should boot successfully.

Additional info:
There was no this issue when clean install rhev-hypervisor6-6.3-20120710.0,upgraded it to rhev-hypervisor6-6.3-20120813.0,then upgraded again to rhev-hypervisor6-6.3-20120815.0
Comment 20 errata-xmlrpc 2013-02-28 11:35:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.