Bug 827385 - Some login link can't redirect to the login page in community on stage-198.
Some login link can't redirect to the login page in community on stage-198.
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 06:12 EDT by yquan
Modified: 2015-05-14 21:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 14:29:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yquan 2012-06-01 06:12:24 EDT
Description of problem:
Some login link can't redirect to the login page in community on stage-198.

Version-Release number of selected component (if applicable):
stage-198

How reproducible:
always

Steps to Reproduce:
1.Configure the stage with enable-sso.sh and revert-features.sh.
2.Go to the community page without login.
3.Go to the Opensource -> index page on left navi bar.
4.Go to any link on wiki page
5.click the login link at bottom.
  
Actual results:
It can't redirect to the login page.
But it can redirect to the login page on dev environment.

Expected results:
This link should redirect to the login page.

Additional info:
Comment 1 Xiaoli Tian 2012-06-04 07:24:39 EDT
This works in prod, might not be a blocker.
Comment 2 Clayton Coleman 2012-06-18 14:29:14 EDT
This is caused by the enable-sso config.  To get this to stop happening in your devenv, update redhat_settings.php with the following:

conf['redhat_sso_login_url'] = 'https://ec2-23-20-107-39.compute-1.amazonaws.com/app/login';
$conf['redhat_sso_logout_url'] = 'https://ec2-23-20-107-39.compute-1.amazonaws.com/app/logout';
$conf['redhat_sso_verify_url'] = $streamline_host . '/wapps/streamline/cloudVerify.html';
$conf['redhat_sso_register_url'] = 'https://ec2-23-20-107-39.compute-1.amazonaws.com/app/account/new';

(specify the full hostname).  In the devenv we don't set this for convenience reasons, in production/staging this is hardcoded.

Note You need to log in before you can comment on or make changes to this bug.