Bug 827416 - [cheese] libv4l2: error setting pixformat: Device or resource busy
[cheese] libv4l2: error setting pixformat: Device or resource busy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cheese (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: beta
: 7.0
Assigned To: David King
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 08:19 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:30:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-06-01 08:19:33 EDT
Description of problem:
Cheese can't record video. Photo and Burst mode works flawlessly.

Version-Release number of selected component (if applicable):
cheese-3.4.2-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run Cheese
2. Select "Video"
3. Click "Record a Video"
  
Actual results:
GUI stops refreshing video preview. Botton "Record a Video" changes to "Stop Recording". No indication of error in GUI.

Expected results:
Video is recorded and saved.

Additional info:

(cheese:2664): Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkButton, but as a GtkBin subclass a GtkButton can only contain one widget at a time; it already contains a widget of type GtkLabel

** (cheese:2664): WARNING **: Could not get buffers from device '/dev/video0'.


** (cheese:2664): WARNING **: Could not map buffers from device '/dev/video0'


** (cheese:2664): WARNING **: Could not negotiate format


** (cheese:2664): WARNING **: Could not get buffers from device '/dev/video0'.


** (cheese:2664): WARNING **: Could not map buffers from device '/dev/video0'


** (cheese:2664): WARNING **: Could not negotiate format

libv4l2: error setting pixformat: Device or resource busy

** (cheese:2664): WARNING **: Device '/dev/video0' is busy


** (cheese:2664): WARNING **: Could not negotiate format
Comment 1 Ludek Smid 2012-06-22 10:40:31 EDT
Not RHEL 7.0 Alpha 2 blocker, reassigning to beta.
Comment 2 Debarshi Ray 2012-10-29 12:22:22 EDT
3.4.2 is too old. I can't reproduce using Cheese 3.6.1 or Git master.

If the problem is still there, can you see what happens with:
$ gst-launch-1.0 v4l2src device=/dev/video0 ! videoconvert ! videoscale ! autovideosink
?
Comment 3 Vitezslav Humpa 2013-11-20 10:01:08 EST
"gst-launch-1.0 v4l2src device=/dev/video0 ! videoconvert ! videoscale ! autovideosink" gives me a window with valid camera input. Also can't reproduce the original bug now with cheese-3.8.2-5.el7.x86_64
Comment 4 Ludek Smid 2014-06-13 08:30:27 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.