Bug 827456 - ssh key not unlocked on login anymore
ssh key not unlocked on login anymore
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 10:14 EDT by David Mansfield
Modified: 2015-03-03 18:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 15:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 662528 None None None 2012-06-04 17:58:01 EDT

  None (edit)
Description David Mansfield 2012-06-01 10:14:51 EDT
Description of problem:
When I login, then open a terminal window, and try ssh, it asks me (in text mode) for my passphrase.  Under Fedora 16 this was unlocked automatically.

Version-Release number of selected component (if applicable):
gnome-keyring-3.4.1-2.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1.login
2.
3.
  
Actual results:
ssh agent does not have key loaded


Expected results:
ssh agent does have key loaded

Additional info:
once I do ssh-add from the command line, it works from then on.
Comment 1 Debarshi Ray 2012-06-06 05:52:59 EDT
The actual upstream bug is against gnome-settings-daemon and it is fixed in 3.4.2. What is your gnome-settings-daemon version?
Comment 2 David Mansfield 2012-06-06 11:48:14 EDT
The version was gnome-settings-daemon-3.4.1-4.fc17.x86_64, which came with F17 (installed with updates repo enabled).

However, I have gotten updates since then, now I'm running 

gnome-settings-daemon-3.4.2-1.fc17.x86_64

and it seems to be working.

Thanks. Bug should be closed.

Note You need to log in before you can comment on or make changes to this bug.