Bug 827489 - ipa-csreplica-manage connect/disconnect options provide inconsistent results
ipa-csreplica-manage connect/disconnect options provide inconsistent results
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Martin Kosek
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 11:25 EDT by Kashyap Chamarthy
Modified: 2016-01-29 08:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 08:00:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kashyap Chamarthy 2012-06-01 11:25:15 EDT
Here is the test scenario:
-----------------------------------------------------------------------------
Master -- neptune ; Replica-1 -- mars ; Replica-2 -- silverbolt ; Replica-3 -- uranus
-----------------------------------------------------------------------------
1] Create Master (neptune)
1.1] Create replica files for Replica-1(mars) and Replica-2(silverbolt). And scp them to
respective machines.

2] On Replica-1(mars): Do a replica install *without* '--setup-ca'

3] On Replica-2(silverbolt): Do a replica install with '--setup-ca'
3.1] Generate a replica file on Replica-2 for Replica-3(uranus)

4] On Replica-3(uranus): Do a replica install with '--setup-ca'
-----------------------------------------------------------------------------

This test is between Replica-2(silverbolt) and Replica-3(uranus):

-> list the agreemtns on Replica-2
=====================
[root@silverbolt slapd-LAB-ENG-PNQ-REDHAT-COM]# ipa-csreplica-manage list -p Secret123
silverbolt.lab.eng.pnq.redhat.com
neptune.lab.eng.pnq.redhat.com
uranus.lab.eng.pnq.redhat.com
=====================

-> Let's do a 'connect' purposefully  (also note: the --verbose doesn't provide any extra
info) on uranus(Replica3)
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose -p Secret123 connect
silverbolt.lab.eng.pnq.redhat.com uranus.lab.eng.pnq.redhat.com
This replication agreement already exists.
=====================

-> Since the replication agreement already exists, let's try to 'disconnect' it. Deleted.
Expected.
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose -p Secret123 disconnect
silverbolt.lab.eng.pnq.redhat.com uranus.lab.eng.pnq.redhat.com
Deleted replication agreement from 'silverbolt.lab.eng.pnq.redhat.com' to
'uranus.lab.eng.pnq.redhat.com'
=====================

-> Let's try to list the agreements of uranus. None. Expected.
=====================
[root@uranus ~]# ipa-csreplica-manage list -p Secret123 uranus.lab.eng.pnq.redhat.com
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose list -p Secret123
uranus.lab.eng.pnq.redhat.com
[root@uranus ~]#
=====================

-> Now, let's try to 'connect' again (since we've disconnected it previously). But here:
it says the 'replication agreement already exists' . How?
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose -p Secret123 connect
silverbolt.lab.eng.pnq.redhat.com uranus.lab.eng.pnq.redhat.com
This replication agreement already exists.
[root@uranus ~]#
=====================

-> Since it says replication agreement exists in the previous command, let's try to
disconnect *again* :
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose -p Secret123 disconnect
silverbolt.lab.eng.pnq.redhat.com uranus.lab.eng.pnq.redhat.com
Cannot remove the last replication link of 'silverbolt.lab.eng.pnq.redhat.com'
Please use the 'del' command to remove it from the domain
[root@uranus ~]#
=====================

-> let's list all the servers for replication on 'uranus'(Replica-3)
=====================
[root@uranus ~]# ipa-csreplica-manage --verbose list -p Secret123
mars.lab.eng.pnq.redhat.com: CA not configured
neptune.lab.eng.pnq.redhat.com: master
silverbolt.lab.eng.pnq.redhat.com: master
uranus.lab.eng.pnq.redhat.com: master
[root@uranus ~]#
=====================
Comment 1 Kashyap Chamarthy 2012-06-01 11:34:39 EDT
Also to note: the --verbose option does not seem to have have any effect.
Comment 3 Rob Crittenden 2012-06-04 22:48:45 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2804
Comment 6 Martin Kosek 2016-01-29 08:00:11 EST
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. Unfortunately, this bug was not given a priority and was deferred both in the upstream project and in Red Hat Enterprise Linux.

Given that we are unable to fulfill this request in following Red Hat Enterprise Linux releases, I am closing the Bugzilla as WONTFIX. To request that Red Hat re-considers the decision, please re-open the Bugzilla via appropriate support channels and provide additional business and/or technical details about its importance to you.

Note that you can still track this request or even contribute patches in the referred upstream Trac ticket.

Note You need to log in before you can comment on or make changes to this bug.