Bug 827502 - IPP backend fails to trigger authentication prompts when a username/password is required
IPP backend fails to trigger authentication prompts when a username/password ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 12:07 EDT by Gianluca Cecchi
Modified: 2012-08-20 09:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 09:13:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Cecchi 2012-06-01 12:07:21 EDT
Description of problem:
I have the same problem as in F16 with
https://bugzilla.redhat.com/show_bug.cgi?id=810007

Version-Release number of selected component (if applicable):
cups-1.5.2-12.fc17.x86_64


How reproducible:
always

Steps to Reproduce:
1. configure a printer with ipp (https)
and connection string 
https://printserver/printers/Stampante3/.printer
(btw my printer server is w2k8 32bit)
2. in printer policies set 
error policy: abort-job (not relevant actually)
operation policy: authenticated 
3. try to print
  
Actual results:
I don't get any prompt for authentication and am unable to print. 
In cups web inteface I see
/usr/lib/cups/backend/https failed

Expected results:
authentication and print

Additional info:

I opened the same problem for F16 and was indeed solved:
https://bugzilla.redhat.com/show_bug.cgi?id=810007

Based on https://bugzilla.redhat.com/show_bug.cgi?id=810007#c24
it should be ok for F17 too.
Just updated my pc (reinstall), but it doesn' work even if I have the version referred....

access_log
localhost - - [01/Jun/2012:17:54:23 +0200] "POST /printers/Stampante3 HTTP/1.1" 401 454 Print-Job successful-ok
localhost - root [01/Jun/2012:17:54:23 +0200] "POST /printers/Stampante3 HTTP/1.1" 200 454 Print-Job successful-ok

error_log
W [01/Jun/2012:17:54:27 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Stampante3-Gray..' already exists
W [01/Jun/2012:17:54:27 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Stampante3-CMYK..' already exists
W [01/Jun/2012:17:54:27 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Stampante3' already exists
Comment 1 Jiri Popelka 2012-06-04 07:43:32 EDT
Hmm, that's strange because cups-1.5.2-12.fc17 has the same patches that fixes it on F16 applied.
Could you also try [1] the cups-1.5.3 from updates-testing. cups-1.5.3 should have this problem [2] fixed [3] upstream.

[1] yum --enablerepo=updates-testing update 'cups*'
[2] http://www.cups.org/str.php?L3985
[3] http://www.cups.org/newsgroups.php?s57+gcups.announce+v75+T0
Comment 2 Gianluca Cecchi 2012-06-05 06:07:40 EDT
The problem arose as soon as I configured the printer.
Tried also to restart cups and no way.
Today I re-tried, before updating, and it works... strange.

BTW: I also took the time to test with success cups-1.5.3-2.fc17.x86_64 from updates-testing repo (with reboot of the system included).

One note: I can print from firefox, evince, but not from libreoffice, where I don't get any user/pwd window but only this in cups web interface:
 /usr/lib/cups/backend/https failed

Donna if this is expected behaviour.
Comment 3 Tim Waugh 2012-08-20 09:13:14 EDT
That sounds like an issue with libreoffice, which uses its own print dialog.

OK, closing this bug report then, as that updates-testing package has been pushed to stable.  If the libreoffice problem persists, please file a bug report against that component.

Note You need to log in before you can comment on or make changes to this bug.