Bug 827575 - Not able to use external PEAR channels
Not able to use external PEAR channels
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 15:14 EDT by Alexander Todorov
Modified: 2015-05-14 18:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2012-06-01 15:14:34 EDT
Description of problem:

With the PHP cartridge:

$ cat deplist.txt 
shupp.github.com/pirum/EZRP

After git push:

remote: Checking pear: shupp.github.com/pirum/EZRP
remote: 
remote: Attempting to discover channel "shupp.github.com/pirum"...
remote: downloading channel.xml ...
remote: Starting to download channel.xml (842 bytes)
remote: ....done: 842 bytes
remote: Channel "shupp.github.com/pirum" is not initialized, use "pear channel-discover shupp.github.com/pirum" to initializeor pear config-set auto_discover 1
remote: unknown channel "shupp.github.com/pirum" in "shupp.github.com/pirum/EZRP"
remote: invalid package name/package file "shupp.github.com/pirum/EZRP"
remote: install failed


Trying manually in the OpenShift shell:

[drupal-otb.rhcloud.com ~]\> pear channel-discover shupp.github.com/pirum
no write access to /var/lib/stickshift/3e88eb0bbcf643dc97447ed63df83c57/.pearrc!


Looks like a perms change will solve it. Please fix this ASAP, there's tons of PHP software outside pear/pecl channels.
Comment 1 Mike McGrath 2012-06-01 15:38:19 EDT
Sorry Alex, this one just missed our cut this time around.  We'll keep the priority high so it gets fixed in our next release.
Comment 2 Rob Millner 2012-06-12 21:38:39 EDT
Commit 4f2b592 in crankcase sets "auto_discover 1" in php applications.
Comment 3 Peter Ruan 2012-06-13 17:46:27 EDT
verfified with devenv_1842 (ami-6ab71403) by creating a php file like the following

<?php

echo bccomp('1', '2');

?>

should see -1 in the page.
Comment 4 Peter Ruan 2012-06-13 17:48:42 EDT
putting it back to ON_QA (previous comment was for another bug).
Comment 5 Peter Ruan 2012-06-13 18:32:11 EDT
The following works, but only it's run the 2nd time.

[myapp-ppp12345.dev.rhcloud.com ~]\>  pear channel-discover shupp.github.com/pirum
no write access to /var/lib/stickshift/2951f80c630346b8ab88a15d3c81e3d3/.pearrc!
[myapp-ppp12345.dev.rhcloud.com ~]\> pear channel-discover shupp.github.com/pirum
Channel "shupp.github.com/pirum" is already initialized
Comment 6 Rob Millner 2012-06-13 21:41:52 EDT
The bugfix was to allow the end-user to specify extra channels in deplist.txt and renders calling "pear channel-discover" unnecessary.
Comment 7 Xiaoli Tian 2012-06-14 04:45:01 EDT
According to comment 5 and comment 6, this bug is fixed.
Comment 8 Chris Ryan 2013-10-21 08:05:52 EDT
I'm still seeing this behavior on the latest devenv-stage_518 (ami-c3326faa). 

Manually: 
[p9-testdomain1.dev.rhcloud.com 5265175853ced3e9610004c3]\> pear channel-discover shupp.github.com/pirum 
no write access to /var/lib/openshift/5265175853ced3e9610004c3//.pearrc!

Also, when going the deplist.txt route, after a git push:
Could not open input file: ~/php/phplib/pear/pear/php/pearcmd.php

Note You need to log in before you can comment on or make changes to this bug.