Bug 827582 - Wizard's git check returns a false negitive on RHEL6
Wizard's git check returns a false negitive on RHEL6
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 15:22 EDT by John (J5) Palmieri
Modified: 2015-05-14 21:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.93.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John (J5) Palmieri 2012-06-01 15:22:38 EDT
I use the newest rhc-0.93.18-1.el6_2.noarch on rhel6.2, and I have installed git in system, rhc still ask me to install or not install git.


root@localhost ~]# rhc setup



Starting Interactive Setup for OpenShift's command line interface



We'll help get you setup with just a couple of questions. You can skip this in the future by copying your config's around:



    /root/.openshift/express.conf

    /root/.ssh/



To connect to int.openshift.redhat.com enter your OpenShift login (email or Red Hat login id): qgong@redhat.com

Password: ******



Configuration file /root/.openshift/express.conf already exists, backing up to /root/.openshift/express.conf.bak



Created local config file: /root/.openshift/express.conf

The express.conf file contains user configuration, and can be transferred to different computers.



No SSH keys were found. We will generate a pair of keys for you.



    Created: /root/.ssh/id_rsa.pub





Your public ssh key must be uploaded to the OpenShift server.  Would you like us to upload it for you? (yes/no) yes



You can enter a name for your key, or leave it blank to use the default name. Using the same name as an existing key will overwrite the old key.



Current Keys:

    None





Since you do not have any keys associated with your OpenShift account, your new key will be uploaded as the default key



Sending new key default .. 

Success



We will now check to see if you have the necessary client tools installed.



Checking for git ... needs to be installed



Would you like to install git with the system installer? (yes/no) Please enter "yes" or "no".

Would you like to install git with the system installer? (yes/no) yes



You may safely continue while the installer is running or you can wait until it has finished.  Press any key to continue:



Checking for your namespace ... not found

Your namespace is unique to your account and is the suffix of the public URLs we assign to your applications. You may configure your namespace here or leave it blank and use 'rhc domain create' to create a namespace later.  You will not be able to create applications without first creating a namespace.



Please enter a namespace or leave this blank if you wish to skip this step:
Comment 1 Rob Millner 2012-06-01 15:27:25 EDT

*** This bug has been marked as a duplicate of bug 826814 ***
Comment 2 John (J5) Palmieri 2012-06-01 15:30:21 EDT
reopening.  I am splitting out bug 826814 into this one since they are unrelated issues (different platforms and code paths)
Comment 3 Meng Bo 2012-06-04 06:25:25 EDT
checked on RHEL6.2, Fedora16, and Mac OSX 
this issue has been fixed, git tool can be detected by rhc setup correctly.

==========
We will now check to see if you have the necessary client tools installed.

Checking for git ... found

Note You need to log in before you can comment on or make changes to this bug.