Bug 827587 - aeolus-configure modifies /etc/ntp.conf causing some lookups to fail
aeolus-configure modifies /etc/ntp.conf causing some lookups to fail
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Mo Morsi
Giulio Fidente
:
: 834350 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-01 15:35 EDT by Ricky Nelson
Modified: 2012-12-04 10:10 EST (History)
6 users (show)

See Also:
Fixed In Version: aeolus-configure-2.8.6-1.el6cf
Doc Type: Bug Fix
Doc Text:
Using aeolus-configure modified the /etc/ntp.conf and caused time sensitive services such as kerberos to fail. This fix ensures the NTP package is installed and the service is running without modifying the configuration. Time sensitive services no longer fail.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Nelson 2012-06-01 15:35:25 EDT
Using aeolus-configure modifies the /etc/ntp.conf. This caused other time-sensitive services to fail after some time (kerberos for example).

CloudForms should only list a requirement for accurate time and not change the NTP configurations itself.
Comment 2 Mo Morsi 2012-07-02 13:39:31 EDT
This is fine, we can ensure the ntp package is installed and the service is running without modifying the configuration.

Patch doing so sent to list

https://fedorahosted.org/pipermail/aeolus-devel/2012-July/011163.html
Comment 3 Matt Wagner 2012-07-02 15:32:27 EDT
*** Bug 834350 has been marked as a duplicate of this bug. ***
Comment 4 Ricky Nelson 2012-07-31 11:58:49 EDT
(In reply to comment #2)
> This is fine, we can ensure the ntp package is installed and the service is
> running without modifying the configuration.
> 
> Patch doing so sent to list
> 
> https://fedorahosted.org/pipermail/aeolus-devel/2012-July/011163.html

Hm. Looks like the archives are no longer at https://fedorahosted.org/pipermail/aeolus-devel/, or the archives are down. I currently get "Environment not found" when going to the archives.

Not sure if this has been vetted or not. Has the aeolus-devel list moved? I'd like to see the possible patch.
Comment 6 Giulio Fidente 2012-09-18 16:03:37 EDT
works for me in aeolus-configure-2.8.6-1.el6cf
Comment 7 Dave Johnson 2012-11-02 12:22:38 EDT
good 2 go

aeolus-configure-2.8.11-1.el6cf.noarch
Comment 9 errata-xmlrpc 2012-12-04 10:10:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.