Bug 827651 - dracut fails to load lvm root
dracut fails to load lvm root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 981439
  Show dependency treegraph
 
Reported: 2012-06-01 21:59 EDT by Pete Travis
Modified: 2013-07-04 13:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 981439 (view as bug list)
Environment:
Last Closed: 2012-11-26 17:40:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blkid output (1.00 KB, text/plain)
2012-06-01 21:59 EDT, Pete Travis
no flags Details
device tree as described with `dmsetup ls --tree` (111 bytes, text/plain)
2012-06-01 22:01 EDT, Pete Travis
no flags Details
attached filesystems as described in /etc/fstab (1.15 KB, text/plain)
2012-06-01 22:01 EDT, Pete Travis
no flags Details
boot configuration from /etc/grub2/grub.cfg (5.32 KB, text/plain)
2012-06-01 22:02 EDT, Pete Travis
no flags Details
output of `lvm lvdisplay` (1.62 KB, text/plain)
2012-06-01 22:03 EDT, Pete Travis
no flags Details
output of `lvm pvdisplay` (376 bytes, text/plain)
2012-06-01 22:03 EDT, Pete Travis
no flags Details
output of `lvm vgdisplay` (629 bytes, text/plain)
2012-06-01 22:04 EDT, Pete Travis
no flags Details
unmodified dracut.conf (1.24 KB, text/plain)
2012-06-01 23:08 EDT, Pete Travis
no flags Details
unmodified lvm.conf (33.37 KB, text/plain)
2012-06-01 23:08 EDT, Pete Travis
no flags Details
init.log with boot line as before (153.67 KB, text/plain)
2012-06-04 10:58 EDT, Pete Travis
no flags Details
init.log with boot parameters as suggested (165.42 KB, text/plain)
2012-06-04 11:00 EDT, Pete Travis
no flags Details
blkid; lvm *display from dracut shell (3.27 KB, text/plain)
2012-06-08 00:17 EDT, Pete Travis
no flags Details

  None (edit)
Description Pete Travis 2012-06-01 21:59:57 EDT
Created attachment 588605 [details]
blkid output

Description of problem:
I've upgraded an up to date F16 installation on my laptop using the installation image.  Unfortunately, I'm dropped into a dracut shell when the lvm root fails to load. Activating the pertinent volumes allows the system to boot without further issues.

I've ran grub2-mkconfig from the new installation to rule out grub configuration issues, the result appears to be correct.

Version-Release number of selected component (if applicable):
Name        : dracut
Version     : 018
Release     : 40.git20120522.fc17

Name        : grub2
Epoch       : 1
Version     : 2.0
Release     : 0.25.beta4.fc17

Name        : lvm2
Version     : 2.02.95
Release     : 6.fc17

How reproducible:

Boot system with configuration as described in attachments.
  
Actual results:
User is required to manually activate logical volumes from dracut shell.

Expected results:
System boots without user intervention.

Additional info:
I don't suspect it's related, but this was a PXE installation that took several attempts due to a flaky broadcom NIC. Anaconda resumed the upgrade seamlessly to complete the process.
Comment 1 Pete Travis 2012-06-01 22:01:00 EDT
Created attachment 588606 [details]
device tree as described with `dmsetup ls --tree`
Comment 2 Pete Travis 2012-06-01 22:01:40 EDT
Created attachment 588607 [details]
attached filesystems as described in /etc/fstab
Comment 3 Pete Travis 2012-06-01 22:02:23 EDT
Created attachment 588608 [details]
boot configuration from /etc/grub2/grub.cfg
Comment 4 Pete Travis 2012-06-01 22:03:16 EDT
Created attachment 588609 [details]
output of `lvm lvdisplay`
Comment 5 Pete Travis 2012-06-01 22:03:51 EDT
Created attachment 588610 [details]
output of `lvm pvdisplay`
Comment 6 Pete Travis 2012-06-01 22:04:23 EDT
Created attachment 588611 [details]
output of `lvm vgdisplay`
Comment 7 Pete Travis 2012-06-01 23:08:08 EDT
Created attachment 588613 [details]
unmodified dracut.conf
Comment 8 Pete Travis 2012-06-01 23:08:57 EDT
Created attachment 588614 [details]
unmodified lvm.conf
Comment 9 Harald Hoyer 2012-06-04 05:28:29 EDT
please boot with "rd.debug" appended to the kernel command line and "rhgb" removed

when you are dropped to the dracut shell save /run/initramfs/init.log and the output of dmesg to a USB stick and attach the files here.

you might also want to try to boot without the "rd.lvm.lv=" parameter

suggested line (yes one line, bugzilla might split it) in /etc/grub2/grub.cfg:

linux /vmlinuz-3.3.7-1.fc17.x86_64 root=UUID=ed9a5ba0-5e95-4a1f-87a2-56c929752826 ro rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.vg=vg_mercury rd.luks=0 LANG=en_US.UTF-8 quiet
Comment 10 Pete Travis 2012-06-04 10:58:20 EDT
Created attachment 589189 [details]
init.log with boot line as before
Comment 11 Pete Travis 2012-06-04 11:00:13 EDT
Created attachment 589190 [details]
init.log with boot parameters as suggested
Comment 12 Pete Travis 2012-06-04 11:03:14 EDT
The suggested line does not resolve the issue. I've attached /run/initramfs/init.log for both the 'factory' appendages and the suggested boot line, hope it's useful. Thanks for the attention,
Pete
Comment 13 Harald Hoyer 2012-06-05 04:53:42 EDT
are the attached files with the blkid and lvm calls from the dracut shell or from the running system? If they are not from the dracut shell, can you please do the same from the dracut shell?

Also interesting:

# ls -l /dev/mapper
Comment 14 Harald Hoyer 2012-06-05 05:06:30 EDT
Oh, and please post from the booted system the output of:

# lsinitrd
# rpm -qa 'dracut*'
# cat /etc/dracut.conf.d/*
Comment 15 Adam Sulmicki 2012-06-06 08:12:04 EDT
the same problem here

preupgrade from Fedora 16 to 17.

on boot i'm dropped into dracut shell with info the root (lvm) was not found.

on manual mounting lvm system boots.
Comment 16 Adam Sulmicki 2012-06-06 08:18:10 EDT
Addendum: 

I instructions on mounting lvm root from dracut I got from : 

http://fedoraproject.org/wiki/How_to_debug_Dracut_problems#Accessing_the_root_volume_from_the_dracut_shell

now on Fedora 17: 
* kernel 3.3.7-1.fc16.x86_64 boots fine.
* kernel 3.3.7-1.fc17.x86_64 drops me into dracut shell.
Comment 17 Harald Hoyer 2012-06-06 10:51:07 EDT
try to regenerate the dracut initramfs:

# dracut -f '' 3.3.7-1.fc17.x86_64
Comment 18 Adam Sulmicki 2012-06-06 15:57:58 EDT
Harald,

This solved my problem. Now 3.3.7-1.fc17.x86_64 boots as fine as 3.3.7-1.fc16.x86_64 did :)

Thanks a lot :)

I guess now the only remaining issue is why it doesn't happen out-of-box with fc17 kernels.
Comment 19 Harald Hoyer 2012-06-07 04:31:08 EDT
(In reply to comment #18)
> Harald,
> 
> This solved my problem. Now 3.3.7-1.fc17.x86_64 boots as fine as
> 3.3.7-1.fc16.x86_64 did :)
> 
> Thanks a lot :)
> 
> I guess now the only remaining issue is why it doesn't happen out-of-box
> with fc17 kernels.

That is a very good question, which I also would like to know! Maybe a recent lvm2 update fixed some issues.
Comment 20 Pete Travis 2012-06-08 00:17:03 EDT
Created attachment 590331 [details]
blkid; lvm *display from dracut shell
Comment 21 Pete Travis 2012-06-08 00:29:13 EDT
(In reply to comment #17)
> try to regenerate the dracut initramfs:
> 
> # dracut -f '' 3.3.7-1.fc17.x86_64

I haven't been able to pull this off, unfortunately. I see there's dracut 018-55.git20120606.fc16 is in -testing, I'll give it a spin.
Comment 22 Pete Travis 2012-11-26 17:40:44 EST
I didn't end up installing the -testing dracut for F16 on my F17 box, naturally...

However, this issue was resolved in subsequent updates to dracut and/or the kernel. Sorry that I can't provide more information than that, and that I left this open with out comment for so long.

Note You need to log in before you can comment on or make changes to this bug.