Bug 827817 - 'help' command in OpenShift shell lacks some commands
'help' command in OpenShift shell lacks some commands
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 03:29 EDT by Matthias Dieter Wallnöfer
Modified: 2015-05-14 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Dieter Wallnöfer 2012-06-03 03:29:42 EDT
(just cosmetic) The help menu available in the OpenShift shell lacks some interesting commands.

This includes:
psql interactive PostgreSQL shell
rhc-list-ports List OpenShift ports


Version-Release number of selected component (if applicable):
current

How reproducible:
type "help" in the shell

Steps to Reproduce:
/
  
Actual results:
/

Expected results:
/

Additional info:
Comment 1 Rob Millner 2012-06-25 19:02:43 EDT
Added psql command in li commit ee421c3; pull request #7.

Not adding rhc-list-ports as that's intended to be called by other scripts.
Comment 2 Meng Bo 2012-06-27 03:26:13 EDT
The fix not include in the devenv_1864, will test it on new build.
Comment 3 Meng Bo 2012-06-28 04:36:21 EDT
Checked on devenv_1868, still no psql in the shell help.

[php1s-bmengdev.dev.rhcloud.com ~]\> help
Help menu: The following commands are available to help control your openshift
application and environment.

ctl_app         control your application (start, stop, restart, etc)
ctl_all         control application and deps like mysql in one command
tail_all        tail all log files
export          list available environment variables
rm              remove files / directories
ls              list files / directories
ps              list running applications
kill            kill running applications
mysql           interactive MySQL shell
mongo           interactive MongoDB shell
quota           list disk usage
Comment 4 Rob Millner 2012-06-28 17:36:29 EDT
devenv_1868 didn't have the commit merged.  The next libra_ami should.
Comment 5 Rony Gong 2012-07-01 23:12:40 EDT
Verified on devenv_1869, show psql
[jbosseap-qgong.dev.rhcloud.com ~]\> help
Help menu: The following commands are available to help control your openshift
application and environment.

ctl_app         control your application (start, stop, restart, etc)
ctl_all         control application and deps like mysql in one command
tail_all        tail all log files
export          list available environment variables
rm              remove files / directories
ls              list files / directories
ps              list running applications
kill            kill running applications
mysql           interactive MySQL shell
mongo           interactive MongoDB shell
psql            interactive PostgreSQL shell
quota           list disk usage

Note You need to log in before you can comment on or make changes to this bug.