Bug 827827 - freetype2-devel package is not available
freetype2-devel package is not available
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 04:19 EDT by Aleksej P.
Modified: 2013-03-03 18:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksej P. 2012-06-03 04:19:07 EDT
Some Python libraries, such as PIL or Pillow, require FreeType2 to be fully functional, but because there is no freetype2-devel, they are being compiled without freetype2 support.
Comment 1 Ram Ranganathan 2012-06-08 15:37:42 EDT
Fixed with git commit 83417eb16cd8bb0f5b8bbbdba02c305bbb9637f6 -- added dependency to freetype-devel as only freetype is available on RHEL-6.2
Comment 2 Xiaoli Tian 2012-06-11 03:22:21 EDT
Verified it on devenv_1827, freetype-devel is installed.

Created a python app, ssh to your app and run freetype-config

[pythonapp-domaindev003.dev.rhcloud.com python2.6]\> freetype-config 
Usage: freetype-config [OPTION]...
Get FreeType compilation and linking information.

Options:
  --prefix               display `--prefix' value used for building the
                         FreeType library
  --prefix=PREFIX        override `--prefix' value with PREFIX
  --exec-prefix          display `--exec-prefix' value used for building
                         the FreeType library
  --exec-prefix=EPREFIX  override `--exec-prefix' value with EPREFIX
  --version              display libtool version of the FreeType library
  --ftversion            display FreeType version number
  --libs                 display flags for linking with the FreeType library
  --libtool              display library name for linking with libtool
  --cflags               display flags for compiling with the FreeType
                         library


#rpm -qf /usr/bin/freetype-config
freetype-devel-2.3.11-6.el6_2.9.x86_64

Note You need to log in before you can comment on or make changes to this bug.