Bug 827847 - An invalid entry in fstab locks up boot for 90 seconds
An invalid entry in fstab locks up boot for 90 seconds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 05:30 EDT by Haakon Riiser
Modified: 2012-06-04 07:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 06:36:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haakon Riiser 2012-06-03 05:30:40 EDT
Description of problem:
If there is an invalid entry in /etc/fstab that is set to be mounted on boot, then the entire boot process locks up completely for approximately 90 seconds before it displays the emergency mode prompt.

Version-Release number of selected component (if applicable):
systemd-44-8.fc17

How reproducible:
Always.

Steps to Reproduce:
1. Add an invalid entry to /etc/fstab, e.g "/dev/sdz9 /mnt vfat defaults 1 1"
2. Save & reboot.

Actual results:
The system hangs on boot.

Expected results:
Either that the emergency prompt appears *immediately* after the mount fails, or that the system simply ignores that it fails and boots normally since this mount is NOT a dependency for *anything*. The 90 second delay where nothing can be done except waiting is incredibly annoying.

Additional info:
When dropping into recovery mode and rebooting using the "reboot" command, even that sometimes hangs.
Comment 1 Michal Schmidt 2012-06-04 06:36:07 EDT
(In reply to comment #0)
> Expected results:
> Either that the emergency prompt appears *immediately* after the mount
> fails,

We do not know in advance if the block device does not exist at all or if it just takes a long time to discover by kernel+udev.

> or that the system simply ignores that it fails and boots normally
> since this mount is NOT a dependency for *anything*.

We cannot safely assume that the filesystem is not important.
There's the "nofail" parameter which you can use to express this property.

> When dropping into recovery mode and rebooting using the "reboot" command,
> even that sometimes hangs.

That sounds like a bug for which we'd like a dedicated bugreport with more details.
Comment 2 Haakon Riiser 2012-06-04 06:52:05 EDT
Is it possible to make Fedora print more verbose status messages during boot? I cannot remember this ever happening on older Fedoras, so when my system became unresponsive during boot, I was always hitting the reset button before it timed out. 90 seconds is a LONG time to wait without any indication that something is happening.
Comment 3 Michal Schmidt 2012-06-04 07:03:33 EDT
I suspect that with systemd-44-12.fc17 you would probably get boot a message like:
  Expecting device /dev/sdz9...
but you may easily overlook it because of messages that are printed later. The boot is parallel and the last message is not necessarily the most important one.

To help with these kinds of issues, one day we'll probably start printing the list of running jobs if nothing is happening during boot for 15 seconds or so. Currently there is nothing like it built-in.

Note You need to log in before you can comment on or make changes to this bug.