Bug 827911 - vesa driver used by default instead of r600g
vesa driver used by default instead of r600g
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
: 827965 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 12:33 EDT by biodark
Modified: 2012-06-05 08:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 08:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot.log (7.62 KB, text/x-log)
2012-06-03 20:00 EDT, biodark
no flags Details
messages log (862.72 KB, text/plain)
2012-06-03 20:00 EDT, biodark
no flags Details
xorg.0 (105.38 KB, text/x-log)
2012-06-03 20:01 EDT, biodark
no flags Details
New messages log (195.78 KB, application/octet-stream)
2012-06-04 19:24 EDT, biodark
no flags Details

  None (edit)
Description biodark 2012-06-03 12:33:53 EDT
Description of problem:
Fedora is very slow, it should be using r600g

Version-Release number of selected component (if applicable):
Latest version.

How reproducible:
Install fedora 17 on foxconn nt-a3500 and restart.

Steps to Reproduce:
Just install fedora 17.
  
Actual results:
Graphics driver used by default is "VESA: WRESTLER"

Expected results:
Graphics driver: r600g

Additional info:
In ubuntu 12.04 it runs r600g out of box but screen suffers much flickering: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/930463
Comment 1 biodark 2012-06-03 20:00:23 EDT
Created attachment 588978 [details]
boot.log
Comment 2 biodark 2012-06-03 20:00:48 EDT
Created attachment 588979 [details]
messages log
Comment 3 biodark 2012-06-03 20:01:09 EDT
Created attachment 588980 [details]
xorg.0
Comment 4 Jérôme Glisse 2012-06-04 10:37:47 EDT
For some reason you have nomodeset on your command line remove that. We don't support nomodeset configuration
Comment 5 biodark 2012-06-04 17:27:59 EDT
This is out of the box installation, I didn't change anything.
Comment 6 biodark 2012-06-04 17:51:31 EDT
If I remove nomodeset the systems doesn't boot to desktop.
Comment 7 Jérôme Glisse 2012-06-04 18:15:33 EDT
Well attach dmesg when booting without nomodeset. You can probably ssh in to retrieve it, otherwise attach full /var/log/messages after doing:
boot without nomodeset
boot with nomodeset
attach /var/log/messages files
Comment 8 biodark 2012-06-04 19:24:20 EDT
Created attachment 589300 [details]
New messages log

Here it is new messages log, this hardware also has bug 827965
Comment 9 Josh Boyer 2012-06-04 19:58:42 EDT
*** Bug 827965 has been marked as a duplicate of this bug. ***
Comment 10 Dave Airlie 2012-06-05 01:54:15 EDT
remove nomodeset and the xorg.conf.
Comment 11 biodark 2012-06-05 02:49:27 EDT
It now boots with r600g when removing xorg.conf and nomodeset, I don't know why a clean fedora install added these.
Comment 12 Adam Jackson 2012-06-05 08:44:04 EDT
Because you installed through the "Basic Graphics" option, which disables the accelerated driver.

Don't have done that.

Note You need to log in before you can comment on or make changes to this bug.