This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 828003 - Internal compiler error: Error reporting routines re-entered with -fstack-usage
Internal compiler error: Error reporting routines re-entered with -fstack-usage
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 20:58 EDT by Serge Pavlovsky
Modified: 2012-08-13 00:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 09:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed output (3.76 MB, application/octet-stream)
2012-06-03 20:58 EDT, Serge Pavlovsky
no flags Details
preprocessed source (1.44 MB, application/octet-stream)
2012-08-13 00:04 EDT, Ryan McDougall
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 53574 None None None 2012-06-04 09:35:37 EDT

  None (edit)
Description Serge Pavlovsky 2012-06-03 20:58:48 EDT
Created attachment 588988 [details]
preprocessed output

Description of problem:
[03:48:35 pal@underdark ~/tmp/1/bug2]$ LANG=C g++ -std=c++11 -fstack-usage -isystem /home/pal/boost/include/boost-1_49_0  -c  -o test1.o test1.cpp 
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/ext/alloc_traits.h:35:0,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/bits/stl_construct.h:63,
                 from /usr/lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/memory:66,
                 from /home/pal/boost/include/boost-1_49_0/boost/config/no_tr1/memory.hpp:21,
                 from /home/pal/boost/include/boost-1_49_0/boost/smart_ptr/shared_ptr.hpp:27,
                 from /home/pal/boost/include/boost-1_49_0/boost/shared_ptr.hpp:17,
                 from /home/pal/boost/include/boost-1_49_0/boost/log/core/core.hpp:23,
                 from /home/pal/boost/include/boost-1_49_0/boost/log/core.hpp:24,
                 from /home/pal/boost/include/boost-1_49_0/boost/log/common.hpp:26,
                 from test1.cpp:1:

Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccTTT4Ny.out file, please attach this to your bugreport.


Version-Release number of selected component (if applicable):

gcc-c++-4.7.0-6.fc17.x86_64
Comment 1 Jakub Jelinek 2012-06-04 03:32:10 EDT
-fstack-usage is option designed for Ada, I don't think it is generally useful for other languages and very likely hasn't been tested at all with them.
That said, the ICE is because output_stack_usage calls lang_decl.decl_printable_name (current_function_decl, 2) quite late in the compilation process, and unqualified_lookup_error is reported during it recursively.  No idea whether that might be affected by free_lang_data or not.
Comment 2 Jakub Jelinek 2012-06-04 09:35:37 EDT
Tracking this upstream as PR53574.
Comment 3 Ryan McDougall 2012-08-13 00:03:07 EDT
I can confirm I get this on gcc-4.7.0-5.fc17.x86_64 and gcc-4.7.1-5.fc18.x86_64

Preprocessed source attached.
Comment 4 Ryan McDougall 2012-08-13 00:04:22 EDT
Created attachment 603846 [details]
preprocessed source

Note You need to log in before you can comment on or make changes to this bug.