Bug 82803 - gnome-theme-manager freezes when there are too many themes
gnome-theme-manager freezes when there are too many themes
Product: Red Hat Raw Hide
Classification: Retired
Component: control-center (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-01-26 14:43 EST by Daniel Brodie
Modified: 2013-04-02 00:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-14 10:43:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Brodie 2003-01-26 14:43:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When using gnome-theme-manager and there are too many themes in
/usr/share/themes (on my machine more then 50) then gnome-theme-manager freezes.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Have more then 50 themes in /usr/share/themes
2. Run gnome-theme-manager
3. Wait for nothing to happen

Actual Results:  The program froze, and dosent do anything.

Expected Results:  gnome-theme-manager should start up.

Additional info:

When using strace it shows that it is trying to write to a socket, and the
program goes into wait. (presumabl not one is emptying the socket)
This is an example with which it freezes on:
write(16, "M249 0 0 /usr/share/themes/Outli"..., 66) = 66
lstat64("/usr/share/themes/OutlineCold", {st_mode=S_IFDIR|0755, st_size=4096,
...}) = 0
lstat64("/usr/share/themes/OutlineCold/index.theme", 0xbffff5e0) = -1 ENOENT (No
such file or directory)
getgroups32(0x20, 0x80a3ee8)            = 7
geteuid32()                             = 0
write(16, "\0\0\0007", 4)               = 4
write(16, "M250 0 0 /usr/share/themes/Outli"..., 55) = 55
lstat64("/usr/share/themes/OutlineCold", {st_mode=S_IFDIR|0755, st_size=4096,
...}) = 0
lstat64("/usr/share/themes/OutlineCold/gtk-2.0/gtkrc", 0xbffff5f0) = -1 ENOENT
(No such file or directory)
brk(0)                                  = 0x80a4000
brk(0x80a5000)                          = 0x80a5000
getgroups32(0x20, 0x80a3ff8)            = 7
geteuid32()                             = 0
write(16, "\0\0\0?", 4)                 = 4
write(16, "M251 0 0 /usr/share/themes/Outli"..., 63 <unfinished ...>

If when it freezes, you check in the proc fs to what the 16 fd is, it turns out
to be a socket. (Someone dosent empty it?)
Comment 1 Jonathan Blandford 2003-01-27 16:27:33 EST
Are you sure it's the number of themes?  Try finding out if it's a specific
theme causing trouble instead of the number of themes.  In particular,
OutlineCold looks like it might be suspect.
Comment 2 Daniel Brodie 2003-01-27 21:49:35 EST
Yes, i tried the removing each theme as it got suck on them, but it just went 
on to the next on. (no in alphabetical order though)
I kept doing this (actually changing them to a .theme_name, but that was 
enough to make it ignore it), but after around 10, when some of them were the 
acssdecibility gnome themes, as i recall, i just got sick of it and copied 
like 20 at once out, and then it worked. I will play around with it more, and 
post more if i find somthing new.
Comment 3 Daniel Brodie 2003-02-06 01:17:46 EST
Ok, i have continued testing it, and i still believe that it is the number of
themes, or somthing along that lines, since as i removed themes from the
begining, it got stuck on other themes at the end.

This bug has been experienced by other users as well, as has been reported by
gnomesupport forums, and the only solutions seems to be to kill fam.

I have not had the time to try out the new gnome-theme-manager from gnome 2.2,
but i will try out soon.
Comment 4 Jonathan Blandford 2003-02-13 16:06:31 EST
Right.  Try upgrading to gnome-vfs2-2-2.1 and see if that fixes it.  I'm pretty
sure this is the fam problem we've been having.
Comment 5 Daniel Brodie 2003-02-14 01:15:35 EST
Thanks, that solved it!

Note You need to log in before you can comment on or make changes to this bug.