Bug 828157 - BUG: lock held when returning to user space! during installation
BUG: lock held when returning to user space! during installation
Status: CLOSED DUPLICATE of bug 825596
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
Unspecified Unspecified
high Severity urgent
: beta
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 07:24 EDT by Adam Okuliar
Modified: 2013-02-15 11:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 11:51:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log while rebooting to rcude3bug kernel (4.24 KB, text/plain)
2012-08-02 05:24 EDT, Endre "Hrebicek" Balint-Nagy
no flags Details

  None (edit)
Description Adam Okuliar 2012-06-04 07:24:06 EDT
Description of problem:
BUG: lock held when returning to user space! and traceback appears during rhel7 installation on 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. grab ibm-x3650m3-02.lab.eng.brq.redhat.com from beaker
2. provision it with latest rhel7 buils

  
Actual results:
  OK  ] Started Terminate Plymouth Boot Screen.
[  OK  ] Started Wait for Plymouth Boot Screen to Quit.
[  OK  ] Stopped systemd-kmsg-syslogd.service.
[  OK  ] Started System Logging Service.
         Starting D-Bus System Message Bus...
[  OK  ] Started D-Bus System Message Bus.
[  OK  ] Started Network Manager.
[  OK  ] Reached target Network.
[  208.751631] 
[  208.753132] ================================================
[  208.753133] [ BUG: lock held when returning to user space! ]
[  208.753135] 3.3.0-0.13.el7.x86_64 #1 Not tainted
[  208.753136] ------------------------------------------------
[  208.753137] NetworkManager/780 is leaving the kernel with locks still held!
[  208.753138] 1 lock held by NetworkManager/780:
[  208.753139]  #0:  (rcu_read_lock){.+.+..}, at: [<ffffffff815f6c99>] inet6_dump_fib+0x79/0x3e0
[  208.754416] BUG: scheduling while atomic: NetworkManager/780/0x00000002
[  208.754418] INFO: lockdep is turned off.
[  208.754419] Modules linked in: cdc_ether usbnet mii serio_raw pcspkr i2c_i801 shpchp ioatdma i2c_core sd_mod crc_t10dif ata_generic pata_acpi ata_piix libata megaraid_sas igb bnx2x mdio dca libcrc32c netxen_nic bnx2 sunrpc xts lrw gf128mul dm_crypt dm_round_robin dm_multipath dm_snapshot dm_mirror dm_region_hash dm_log dm_zero dm_mod linear raid10 raid456 async_raid6_recov async_memcpy async_pq raid6_pq async_xor xor async_tx raid1 raid0 iscsi_ibft iscsi_boot_sysfs edd iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi squashfs cramfs
[  208.754444] Pid: 780, comm: NetworkManager Not tainted 3.3.0-0.13.el7.x86_64 #1
[  208.754446] Call Trace:
[  208.754450]  [<ffffffff81655e24>] __schedule_bug+0x80/0x85
[  208.754454]  [<ffffffff81660cad>] __schedule+0x8dd/0x9a0
[  208.754456]  [<ffffffff816610bf>] schedule+0x3f/0x60
[  208.754460]  [<ffffffff810d2e49>] futex_wait_queue_me+0xc9/0x100
[  208.754462]  [<ffffffff810d35ba>] futex_wait+0x19a/0x2e0
[  208.754466]  [<ffffffff8107dec4>] ? set_current_blocked+0x34/0x60
[  208.754468]  [<ffffffff810d5485>] do_futex+0x115/0xa60
[  208.754471]  [<ffffffff8107dee2>] ? set_current_blocked+0x52/0x60
[  208.754473]  [<ffffffff8107dfc6>] ? block_sigmask+0x46/0x50
[  208.754477]  [<ffffffff810187f9>] ? do_signal+0x139/0x300
[  208.754479]  [<ffffffff81654c29>] ? is_prefetch.isra.13+0xc8/0x200
[  208.754482]  [<ffffffff811befe2>] ? fget_light+0x62/0x4a0
[  208.754484]  [<ffffffff810d5ed7>] sys_futex+0x107/0x1a0
[  208.754488]  [<ffffffff81331a04>] ? lockdep_sys_exit_thunk+0x35/0x67
[  208.754490]  [<ffffffff8133198e>] ? trace_hardirqs_on_thunk+0x3a/0x3f
[  208.754493]  [<ffffffff8166b869>] system_call_fastpath+0x16/0x1b

then anaconda ends with exception

Expected results:
correct system installation

Additional info:
please mail or ping me anytime if you want to investigate this issue. I will give you access to afected machine.
Comment 3 Endre "Hrebicek" Balint-Nagy 2012-08-02 05:24:30 EDT
Created attachment 601909 [details]
log while rebooting to rcude3bug kernel

I have no kernel-firmware package for this kernel, I suppose this is the root cause for this panic.
In the beginning there is a mention of the watchdog, being unexpectedly closed.
It is an other bug against the f17 kernel?
If you think it is still vital to get a log from rcudebug kernel, please re-brew it to have the firmware next time.
Comment 5 Neil Horman 2013-02-15 11:51:59 EST

*** This bug has been marked as a duplicate of bug 825596 ***

Note You need to log in before you can comment on or make changes to this bug.